[ 
https://issues.apache.org/jira/browse/YARN-3164?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14316851#comment-14316851
 ] 

Allen Wittenauer commented on YARN-3164:
----------------------------------------

Adding a unit test for this is a waste of time, IMO. 

I'm much more curious why we are override the method rather than just changing 
the text directly.  Does anything else actually even use the method that's 
being overridden?  

(In general, having this method even exist seems like a strong case of 
over-engineering, which is pretty prevalent throughout Hadoop.)

> rmadmin command usage prints incorrect command name
> ---------------------------------------------------
>
>                 Key: YARN-3164
>                 URL: https://issues.apache.org/jira/browse/YARN-3164
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: resourcemanager
>    Affects Versions: 2.6.0
>            Reporter: Bibin A Chundatt
>            Assignee: Bibin A Chundatt
>            Priority: Minor
>         Attachments: YARN-3164.1.patch
>
>
> /hadoop/bin>{color:red} ./yarn rmadmin -transitionToActive {color}
> transitionToActive: incorrect number of arguments
> Usage:{color:red}  HAAdmin  {color} [-transitionToActive <serviceId> 
> [--forceactive]]
> >{color:red} ./yarn HAAdmin {color} 
> Error: Could not find or load main class HAAdmin
> Expected it should be rmadmin



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to