[ 
https://issues.apache.org/jira/browse/YARN-2799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14330300#comment-14330300
 ] 

Hudson commented on YARN-2799:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #102 (See 
[https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/102/])
YARN-2799. Cleanup TestLogAggregationService based on the change in YARN-90. 
Contributed by Zhihai Xu (junping_du: rev 
c33ae271c24f0770c9735ccd2086cafda4f4e0b2)
* hadoop-yarn-project/CHANGES.txt
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/logaggregation/TestLogAggregationService.java


> cleanup TestLogAggregationService based on the change in YARN-90
> ----------------------------------------------------------------
>
>                 Key: YARN-2799
>                 URL: https://issues.apache.org/jira/browse/YARN-2799
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: test
>            Reporter: zhihai xu
>            Assignee: zhihai xu
>            Priority: Minor
>             Fix For: 2.7.0
>
>         Attachments: YARN-2799.000.patch, YARN-2799.001.patch, 
> YARN-2799.002.patch
>
>
> cleanup TestLogAggregationService based on the change in YARN-90.
> The following code is added to setup in YARN-90, 
> {code}
>     dispatcher = createDispatcher();
>     appEventHandler = mock(EventHandler.class);
>     dispatcher.register(ApplicationEventType.class, appEventHandler);
> {code}
> In this case, we should remove all these code from each test function to 
> avoid duplicate code.
> Same for dispatcher.stop() which is in tearDown,
> we can remove dispatcher.stop() from from each test function also because it 
> will always be called from tearDown for each test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to