Zhijie Shen commented on YARN-3264:

The patch looks almost good. Two minor issue:

1. Should we still keep TimelineAggregator  "abstract"?

2. To be consistent, how about renaming: TimelineServiceWriteResponse -> 
TimelineWriteResponse, TimelineServiceWriteError ->TimelineWriteResponse, and  
TimelineServiceWriter(Impl) -> TimelineWriter(Impl) and so on

> [Storage implementation] Create backing storage write interface and  a POC 
> only file based storage implementation
> -----------------------------------------------------------------------------------------------------------------
>                 Key: YARN-3264
>                 URL: https://issues.apache.org/jira/browse/YARN-3264
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>            Reporter: Vrushali C
>            Assignee: Vrushali C
>         Attachments: YARN-3264.001.patch, YARN-3264.002.patch, 
> YARN-3264.003.patch, YARN-3264.004.patch, YARN-3264.005.patch
> For the PoC, need to create a backend impl for file based storage of entities 

This message was sent by Atlassian JIRA

Reply via email to