[ 
https://issues.apache.org/jira/browse/YARN-3423?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

zhaoyunjiong updated YARN-3423:
-------------------------------
    Attachment: YARN-3423.patch

Update patch, the previous patch is not right.
Below are configs from our cluster:
{code}
yarn.resourcemanager.hostname   0.0.0.0
yarn.resourcemanager.webapp.https.address       0.0.0.0:8090
yarn.resourcemanager.webapp.https.address.rm1 rm-1.vip.ebay.com:50030
yarn.resourcemanager.webapp.https.address.rm2 rm-2.vip.ebay.com:50030
{code}

In AppController.java, when calling 
WebAppUtils.getResolvedRMWebAppURLWithoutScheme it will get wrong hostname:
{code}
  public static String getResolvedRMWebAppURLWithoutScheme(Configuration conf,
      Policy httpPolicy) {
    InetSocketAddress address = null;
    if (httpPolicy == Policy.HTTPS_ONLY) {
      address =
          conf.getSocketAddr(YarnConfiguration.RM_WEBAPP_HTTPS_ADDRESS,
              YarnConfiguration.DEFAULT_RM_WEBAPP_HTTPS_ADDRESS,
              YarnConfiguration.DEFAULT_RM_WEBAPP_HTTPS_PORT);
    } else {
      address =
          conf.getSocketAddr(YarnConfiguration.RM_WEBAPP_ADDRESS,
              YarnConfiguration.DEFAULT_RM_WEBAPP_ADDRESS,
              YarnConfiguration.DEFAULT_RM_WEBAPP_PORT);      
    }
//address = "0.0.0.0:8090", so getResolvedAddress will return the hostname of 
Application master, because it runs on it.
    return getResolvedAddress(address);
  }
{code}

> RM HA setup, "Cluster" tab links populated with AM hostname instead of RM 
> --------------------------------------------------------------------------
>
>                 Key: YARN-3423
>                 URL: https://issues.apache.org/jira/browse/YARN-3423
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: resourcemanager
>    Affects Versions: 2.4.0
>         Environment: centOS-6.x 
>            Reporter: Aroop Maliakkal
>            Priority: Minor
>         Attachments: YARN-3423.patch
>
>
> In RM HA setup ( e.g. 
> http://rm-1.vip.abc.com:50030/proxy/application_1427789305393_0002/ ), go to 
> the job details and click on the "Cluster tab" on left top side. Click on any 
> of the links , "About", Applications" , "Scheduler". You can see that the 
> hyperlink is pointing to http://am-1.vip.abc.com:port/cluster ).
> The port details for secure and unsecure cluster is given below :-
>   8088 ( DEFAULT_RM_WEBAPP_PORT = 8088 )
>   8090  ( DEFAULT_RM_WEBAPP_HTTPS_PORT = 8090 )
> Ideally, it should have pointed to resourcemanager hostname instead of AM 
> hostname.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to