sandflee created YARN-3546:

             Summary: AbstractYarnScheduler.getApplicationAttempt seems 
misleading,  and there're some misuse of it
                 Key: YARN-3546
             Project: Hadoop YARN
          Issue Type: Bug
          Components: resourcemanager
            Reporter: sandflee

I'm not familiar with scheduler,  with first eyes, I thought this func returns 
the schdulerAppAttempt info corresponding to appAttemptId, but actually it 
returns the current schdulerAppAttempt.
It seems misled others too, such as
should I rename it to T getCurrentSchedulerApplicationAttempt(ApplicationId 
or returns null  if current attempt id not equals to the request attempt id ?
comment preferred!

This message was sent by Atlassian JIRA

Reply via email to