[ 
https://issues.apache.org/jira/browse/YARN-1519?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Eric Payne updated YARN-1519:
-----------------------------
    Attachment: YARN-1519.003.patch

[~hsn], since I didn't hear back, I will go ahead and post the patch with the 
changes suggested by [~raviprak]. Thanks again for doing all of the work and 
testing on this patch.

[~raviprak], will you please have a look? Thanks.


> check if sysconf is implemented before using it
> -----------------------------------------------
>
>                 Key: YARN-1519
>                 URL: https://issues.apache.org/jira/browse/YARN-1519
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager
>    Affects Versions: 3.0.0, 2.3.0
>            Reporter: Radim Kolar
>            Assignee: Radim Kolar
>              Labels: BB2015-05-TBR
>         Attachments: YARN-1519.002.patch, YARN-1519.003.patch, 
> nodemgr-sysconf.txt
>
>
> If sysconf value _SC_GETPW_R_SIZE_MAX is not implemented, it leads to 
> segfault because invalid pointer gets passed to libc function.
> fix: enforce minimum value 1024, same method is used in hadoop-common native 
> code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to