Allen Wittenauer commented on YARN-3170:

and job scheduling/monitoring, 

Unnecessary comma.

The Scheduler has a pluggable policy plug-in,

Awkward phrasing.  Unnecessary comma.

In the first version, only memory is supported.

Remove.  It isn't true anymore and highlights one of the things I absolutely 
hate about Hadoop documentation:  roadmaps don't belong here. 

The current MapReduce schedulers such as the CapacityScheduler and the 
FairScheduler would be some examples of the plug-in.

"MapReduce" should be removed.  "of plug-ins"; no the & make it plural.  Also 
link to their respective documentation pages.

The CapacityScheduler supports hierarchical queues to allow for more 
predictable sharing of cluster resources

Drop this sentence.

> YARN architecture document needs updating
> -----------------------------------------
>                 Key: YARN-3170
>                 URL: https://issues.apache.org/jira/browse/YARN-3170
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: documentation
>            Reporter: Allen Wittenauer
>            Assignee: Brahma Reddy Battula
>         Attachments: YARN-3170-002.patch, YARN-3170-003.patch, 
> YARN-3170-004.patch, YARN-3170-005.patch, YARN-3170-006.patch, 
> YARN-3170-007.patch, YARN-3170-008.patch, YARN-3170.patch
> The marketing paragraph at the top, "NextGen MapReduce", etc are all 
> marketing rather than actual descriptions. It also needs some general 
> updates, esp given it reads as though 0.23 was just released yesterday.

This message was sent by Atlassian JIRA

Reply via email to