[ 
https://issues.apache.org/jira/browse/YARN-3706?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Joep Rottinghuis updated YARN-3706:
-----------------------------------
    Attachment: YARN-3726-YARN-2928.007.patch

YARN-3726-YARN-2928.007.patch :

Renamed ColumnImpl to ColumnHelper to clarify relationship to *Column<T> 
instances of interface Column<t>

TimelineWriterUtils.encode needed two things per separator, the original and 
the URLencoded version.
I like the idea of not having to URLEncode the separators over and over again, 
so I made separators a separate class with their own behavior.
That ends up working out much cleaner now. No more URLEncoding and Decoding on 
the fly over and over. Byte representation is calculated once and reused. 
Encoding and decoding logic moved to Separator class, which is nicer than 
stashing too many things in the helper class.

Also found out that URLEncoding does actually HTML encoding and encodes space 
as plus, which is an issue when the values contain a plus. Chose different 
encoding that does not seem likely to be used in source, so even URL encoded 
strings can be used as identifiers now.

Patch is ready for review again.




> Generalize native HBase writer for additional tables
> ----------------------------------------------------
>
>                 Key: YARN-3706
>                 URL: https://issues.apache.org/jira/browse/YARN-3706
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>            Reporter: Joep Rottinghuis
>            Assignee: Joep Rottinghuis
>            Priority: Minor
>         Attachments: YARN-3706-YARN-2928.001.patch, 
> YARN-3726-YARN-2928.002.patch, YARN-3726-YARN-2928.003.patch, 
> YARN-3726-YARN-2928.004.patch, YARN-3726-YARN-2928.005.patch, 
> YARN-3726-YARN-2928.006.patch, YARN-3726-YARN-2928.007.patch
>
>
> When reviewing YARN-3411 we noticed that we could change the class hierarchy 
> a little in order to accommodate additional tables easily.
> In order to get ready for benchmark testing we left the original layout in 
> place, as performance would not be impacted by the code hierarchy.
> Here is a separate jira to address the hierarchy.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to