[ 
https://issues.apache.org/jira/browse/YARN-1012?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14614010#comment-14614010
 ] 

Karthik Kambatla commented on YARN-1012:
----------------------------------------

Sorry for the delay in getting around to this. In addition to Vinod's comments, 
a few more:
# Unused imports added in ContainerImpl, MockContainer, NodeHealthStatusPBImpl, 
NodeStatusUpdaterImpl
# ContainersMontiorImpl
## Rename auxContainersUtilization to trackedContainersUtilization or 
tmpContainersUtilization for clarity. auxContainersUtilization could lead 
people to think about auxiliary services.
## Nit: might be premature optimization. Instead of 
{{ResourceUtilizations#addTo(ResourceUtilization)}}, did we consider 
{{ResourceUtilization#addTo(pmem, vmem, cpu)}}?
# NodeStatusUpdaterImpl: Instead of adding a getContainersUtilization method 
and using the returned value immediately, how about adding a 
setContainersUtilizationInHealthStatus? 
# ResourceUtilization
## License header has some unrelated numbers
## In {{hashCode}}, instead of using 939769357, we should probably do {{prime * 
result}}? 
# ResourceUtilizations
## Looks like we only use addTo, how about getting rid of the remaining methods 
for now? 
## Also, if we move that addTo to ResourceUtilization itself, we will not be 
needing another class.
## If we do choose to keep the class, we should probably annotate it Private 
and not LimitedPrivate. Do we see MapReduce using this? 

> Report NM aggregated container resource utilization in heartbeat
> ----------------------------------------------------------------
>
>                 Key: YARN-1012
>                 URL: https://issues.apache.org/jira/browse/YARN-1012
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>    Affects Versions: 2.7.0
>            Reporter: Arun C Murthy
>            Assignee: Inigo Goiri
>         Attachments: YARN-1012-1.patch, YARN-1012-2.patch, YARN-1012-3.patch, 
> YARN-1012-4.patch, YARN-1012-5.patch, YARN-1012-6.patch, YARN-1012-7.patch, 
> YARN-1012-8.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to