[ 
https://issues.apache.org/jira/browse/YARN-3916?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14624018#comment-14624018
 ] 

Wangda Tan commented on YARN-3916:
----------------------------------

[~varun_saxena],
Thanks for updating, but I think the comment may not accurate enough if I 
understand correctly: the flag == true when dispatcher is processing events OR 
dispatcher has pending events, maybe rename it to something like "isIdle" is 
more accurate.

Thoughts?

> DrainDispatcher#await should wait till event has been completely handled
> ------------------------------------------------------------------------
>
>                 Key: YARN-3916
>                 URL: https://issues.apache.org/jira/browse/YARN-3916
>             Project: Hadoop YARN
>          Issue Type: Bug
>    Affects Versions: 2.7.0
>            Reporter: Varun Saxena
>            Assignee: Varun Saxena
>            Priority: Critical
>         Attachments: YARN-3916.01.patch, YARN-3916.02.patch
>
>
> DrainDispatcher#await should wait till event has been completely handled.
> Currently it only checks for whether event queue has become empty.
> And in many tests we directly check for a state to be changed after calling 
> await.
> Sometimes, the states do not change by the time we check them as event has 
> not been completely handled.
> *This is causing test failures* such as YARN-3909 and YARN-3910 and may cause 
> other test failures as well.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to