Subru Krishnan updated YARN-3974:
    Attachment: YARN-3974-v3.patch

Thanks [~adhoot] for the feedback and the updated patch. I have simplified the 
patch further:
   * by directly using _schedulerType_ instead of adding a new 
   * renamed getreservationQueueName -> getReservationQueueName
   * cleaning up unused methods
   * fixed minor checkstyle & javadoc issues due to merge of YARN-3656

> Refactor the reservation system test cases to use parameterized base test
> -------------------------------------------------------------------------
>                 Key: YARN-3974
>                 URL: https://issues.apache.org/jira/browse/YARN-3974
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler, fairscheduler
>            Reporter: Subru Krishnan
>            Assignee: Subru Krishnan
>         Attachments: YARN-3974-v1.patch, YARN-3974-v2.patch, 
> YARN-3974-v3.patch
> We have two test suites for testing ReservationSystem against Capacity & Fair 
> scheduler. We should combine them using a parametrized reservation system 
> base test similar to YARN-2797

This message was sent by Atlassian JIRA

Reply via email to