Wangda Tan commented on YARN-3813:

Thanks [~nijel] and [~rohithsharma] for working on this, it is a very useful 
feature to me.

Comments for existing patch:
- Instead of Timeout-, is it better to rename it to "lifetime"? Timeout will 
confuse people with the application-heartbeat-timeout.
- synchronized lock in RMAppTimeOutMonitor is unnecessary, you can use 
putIfAbsent instead, and remove doesn't need to do check its existence
- All LOG.debug should be placed in LOG.isDebugEnabled
- threadSleepTime -> something like monitoringInterval?

Some questions about some related tasks/plans:
- Do you plan to support updating lifetime when the application is running?
- Do you plan to get lifetime via ApplicationReport, CLI, REST API?


> Support Application timeout feature in YARN. 
> ---------------------------------------------
>                 Key: YARN-3813
>                 URL: https://issues.apache.org/jira/browse/YARN-3813
>             Project: Hadoop YARN
>          Issue Type: New Feature
>          Components: scheduler
>            Reporter: nijel
>            Assignee: nijel
>         Attachments: 0001-YARN-3813.patch, 0002_YARN-3813.patch, YARN 
> Application Timeout .pdf
> It will be useful to support Application Timeout in YARN. Some use cases are 
> not worried about the output of the applications if the application is not 
> completed in a specific time. 
> *Background:*
> The requirement is to show the CDR statistics of last few  minutes, say for 
> every 5 minutes. The same Job will run continuously with different dataset.
> So one job will be started in every 5 minutes. The estimate time for this 
> task is 2 minutes or lesser time. 
> If the application is not completing in the given time the output is not 
> useful.
> *Proposal*
> So idea is to support application timeout, with which timeout parameter is 
> given while submitting the job. 
> Here, user is expecting to finish (complete or kill) the application in the 
> given time.
> One option for us is to move this logic to Application client (who submit the 
> job). 
> But it will be nice if it can be generic logic and can make more robust.
> Kindly provide your suggestions/opinion on this feature. If it sounds good, i 
> will update the design doc and prototype patch

This message was sent by Atlassian JIRA

Reply via email to