Wangda Tan commented on YARN-4205:


- Could you add a short desc of this JIRA?
- {{LOG.debug("Starting RMAppLifeTimeMonitorThread.");}} need add 
isDebugEnabled check
- RMAppLifeTimeMonitorService.rmApps -> applicationIdToLifetime? (or shorter 
name if you prefer), it's not rmApps actually
- life time or lifetime? I prefer "life time", "LifeTime", "lifetime" in your 
patch, I prefer use "lifetime" for consistency.
- I can found some "timeout" in your patch, use "lifetime" instead?
- {{public synchronized void unregister}}, synchronized could be removed?

> Add a service for monitoring application life time out
> ------------------------------------------------------
>                 Key: YARN-4205
>                 URL: https://issues.apache.org/jira/browse/YARN-4205
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: scheduler
>            Reporter: nijel
>            Assignee: nijel
>         Attachments: YARN-4205_01.patch

This message was sent by Atlassian JIRA

Reply via email to