Eric Payne commented on YARN-4226:

Since the {{preemptionDisabled}} tag has already shipped with the capacity 
scheduler's REST API, I don't think that changing the name of the tag is an 
option, since users may be relying on that key string. I see only the following 
# Change the value of {{true}} to {{disabled}} and {{false}} to {{enabled}} 
(which may not be an option either for the same reason changing the key is not 
an option)
# Add a new key like {{preemptionStatus}} and have the values be {{enabled}} or 
# Make no changes. Leave it the way that it is

> Make capacity scheduler queue's preemption status REST API consistent with GUI
> ------------------------------------------------------------------------------
>                 Key: YARN-4226
>                 URL: https://issues.apache.org/jira/browse/YARN-4226
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: capacity scheduler, yarn
>    Affects Versions: 2.7.1
>            Reporter: Eric Payne
>            Assignee: Eric Payne
>            Priority: Minor
> In the capacity scheduler GUI, the preemption status has the following form:
> {code}
> Preemption:   disabled
> {code}
> However, the REST API shows the following for the same status:
> {code}
> preemptionDisabled":true
> {code}
> The latter is confusing and should be consistent with the format in the GUI.

This message was sent by Atlassian JIRA

Reply via email to