On 11 October 2016 at 06:18, Dinh Nguyen (dinhn) <di...@cisco.com> wrote:

> ERROR: QA Issue: Architecture did not match (20 to 62) on
> /work/ppce500v2-poky-linux-gnuspe/c-mlib/1.1-r0/packages-split/c-mlib/usr/bin/xxx
>  [arch]

You can look up the architectures at
https://en.wikipedia.org/wiki/Executable_and_Linkable_Format to discover
that indeed it has detected that your binary is compiled as x86-64 (62 or
0x3E) but target executes should be PPC (20 or 0x14).

This is usually caused by your recipe build using 'gcc' directly and not
using the cross-compiler, so you'll need to look at the makefiles and see
if you can tell it to use a different compiler.

yocto mailing list

Reply via email to