Actually the problem didn't come from doing IMAGE_INSTALL +=.

The problem came from the fact that in my recipe, I was adding the "IMAGE_INSTALL +=" line before the "inherit core-image" in which IMAGE_INSTALL is defined as a ?=. By doing that, the packages defined in the core-image class are not added because the variable IMAGE_INSTALL already exists.

Adding the "IMAGE_INSTALL +=" line after "inherit core-image" solved the problem.

I decided to use xfce as GUI because a recipe for the whole package exists (packagegroup-xfce-base).

Thanks for your help

*Quentin Gouès*
Ingénieur Développement Logiciel

14, rue Charles Martigny
Tel. +33 (0)1 42 07 18 00 - Fax +33 (0)1 42 07 85 55 <>

Le 28/02/2018 à 17:17, Burton, Ross a écrit :
Because by doing IMAGE_INSTALL += you wiped out the default value which is a ?=.

gnome-desktop3 isn't the GNOME interface though, it's just a small library.

If you want the full GNOME 3 desktop then you'll need to start with meta-gnome and write more recipes, as it's not entirely packaged.


On 28 February 2018 at 14:10, Q. Gouès < <>> wrote:


    I am trying to add gnome to my x11 image based on the recipe
    core-image-x11. I am using Poky 2.0 (Jethro).

    For that, I added the following line to my recipe:

    /IMAGE_INSTALL += "gnome-desktop3"/

    Unfortunately I get the following error:

    /switch_root: can't execute '/sbin/init': No such file or directory//
    //Kernel panic - not syncing: Attempted to kill init!

    I tried the same thing with XFCE (I am trying to add a window
    manager to my image) and I got the same results.

    After taking a look at the rootfs in the iso file, I can notice
    that the file '/sbin/init' is indeed missing. And it's not the
    only file missing ! The rootfs went from ~420Mo to ~220Mo and the
    list of files present in the rootfs went from:

    //blkid -> /bin/busybox.nosuid//
    //depmod -> /sbin/depmod.kmod//
    //depmod.kmod -> ../bin/kmod//
    //fdisk -> /bin/busybox.nosuid//
    //fsck -> /bin/busybox.nosuid//
    //fstrim -> /bin/busybox.nosuid//
    //getty -> /bin/busybox.nosuid//
    //halt -> /sbin/halt.sysvinit//
    //hdparm -> /sbin/hdparm.hdparm//
    //hwclock -> /bin/busybox.nosuid//
    //ifconfig -> /bin/busybox.nosuid//
    //ifdown -> /bin/busybox.nosuid//
    //ifup -> /bin/busybox.nosuid//
    //init -> /sbin/init.sysvinit//
    //insmod -> /sbin/insmod.kmod//
    //insmod.kmod -> ../bin/kmod//
    //ip -> /bin/busybox.nosuid//
    //iwgetid -> iwconfig//
    //iwlist -> iwconfig//
    //iwpriv -> iwconfig//
    //iwspy -> iwconfig//
    //klogd -> /bin/busybox.nosuid//
    //loadkmap -> /bin/busybox.nosuid//
    //logread -> /bin/busybox.nosuid//
    //losetup -> /bin/busybox.nosuid//
    //lsmod -> /bin/lsmod.kmod//
    //mkswap -> /bin/busybox.nosuid//
    //modinfo -> /sbin/modinfo.kmod//
    //modinfo.kmod -> ../bin/kmod//
    //modprobe -> /sbin/modprobe.kmod//
    //modprobe.kmod -> ../bin/kmod//
    //pivot_root -> /bin/busybox.nosuid//
    //poweroff -> /sbin/poweroff.sysvinit//
    //poweroff.sysvinit -> halt.sysvinit//
    //reboot -> /sbin/reboot.sysvinit//
    //reboot.sysvinit -> halt.sysvinit//
    //rmmod -> /sbin/rmmod.kmod//
    //rmmod.kmod -> ../bin/kmod//
    //route -> /bin/busybox.nosuid//
    //runlevel -> /sbin/runlevel.sysvinit//
    //setconsole -> /bin/busybox.nosuid//
    //shutdown -> /sbin/shutdown.sysvinit//
    //start-stop-daemon -> /bin/busybox.nosuid//
    //sulogin -> /sbin/sulogin.util-linux//
    //swapoff -> /bin/busybox.nosuid//
    //swapon -> /bin/busybox.nosuid//
    //switch_root -> /bin/busybox.nosuid//
    //sysctl -> /bin/busybox.nosuid//
    //syslogd -> /bin/busybox.nosuid//
    //telinit -> init//
    //udhcpc -> /bin/busybox.nosuid//
    //vigr -> /sbin/vigr.shadow//
    //vigr.shadow -> vipw.shadow//
    //vipw -> /sbin/vipw.shadow//


    //sulogin -> /sbin/sulogin.util-linux//
    //vigr -> /sbin/vigr.shadow//
    //vigr.shadow -> vipw.shadow//
    //vipw -> /sbin/vipw.shadow//

    It looks like busybox was removed as well as other packages.

    Do you have any idea why all these packages have been removed ?



    yocto mailing list <>

yocto mailing list

Reply via email to