I'm having some trouble with native dependencies in my recipe, and I'm 
wondering if anyone has any tips.  I'm building with the petalinux toolset on 
an x64 linux for an arm architecture.

I have a recipe myapp, which has a native version, myapp-native.  myapp depends 
on its myapp-native, as this builds an application used in the build of myapp.  
myapp also depends on a kernel module, mymodule.

So, an excerpt from myapp.bb:

DEPENDS += "mymodule myapp-native"

The problem that myapp-native is trying to include mymodule-native.  This 

ERROR: Nothing PROVIDES 'mymodule-native' (but 
virtual:native:/path/.../myapp/myapp.bb DEPENDS on or otherwise requires it)

I've tried adding a 'BBCLASSEXTEND = "native"' to mymodule.bb, but that 
generated build errors.

I've tried overriding the dependency in myapp.bb with
DEPENDS-native = ""

And then I tried adding this to myapp.bb
DEPENDS_${PN}-native = ""

I've also tried allowing the mymodule-native package to be empty by adding this 
to mymodule.bb

As well as this:
ALLOW_EMPTY_${PN}-native = "1"

But nothing seems to work... it keeps trying to find mymodule-native.  I'd like 
a way to either override this dependency or make mymodule-native an empty 
package.  I'm all out of random spaghetti to throw against this wall, and I'm 
hoping someone has some experience with this.

yocto mailing list

Reply via email to