I tried also with an enlarger UDP packet and still no success.
It appears it is a DNS only problem, as the UA queries the DNS server
for _sip._udp.domain
Do you know if in successfull deployments of yxa is it possible to use a
SIP server without the use of an DNS server ?



În data de Sb, 14-03-2009 la 16:44 +0100, Fredrik Thulin a scris:

> Costin-Tiberiu RADU wrote:
> ...
> >
> >  debug<0.331.0>:Transport layer: Failed sending request (1353 bytes) to udp:
> > 192.168.34.148:5069, error eaddrnotavail
> 
> I've never seen an eaddrnotavail before - not sure what that is. Do you 
> have some kind of exotic interface connection, like IP aliases on the 
> server or similar? What operating system?
> 
> ...
> > From this behavior  I  understand that despite the server sending 200 OK
> > messages upon registration to the two UAs, when it comes down to allowing
> > them to talk to each other it does not know where they are.
> 
> Well, if that is the case then the clients are not using their real 
> addresses in the Contact header of the REGISTER messages, when 
> registering. Otherwise, the problem is more likely to be that YXA for 
> some reason can't send UDP datagrams to the client.
> 
> Did you try what I suggested about udp_max_datagram_size? The "Failed 
> sending request (1353 bytes) to udp:" further suggests that the problem 
> might be that the INVITE is larger than 1200 bytes, which is the default 
> limit for udp_max_datagram_size.

Tried with 3000, no success.

> 
> > Is there a way I can see which users are at a given moment registered ?
> > (besides direct queries to the mnesia database)
> 
> Set up the web interface, or start incomingproxy with "-d" to get an 
> erlang shell. At the erlang shell prompt, enter
> 
>    phone:list_phones().

Thanks, this was very helpfull.


> 
> /Fredrik

Attachment: signature.asc
Description: Aceast fragment din mesaj este semnat digital

_______________________________________________
Yxa-devel mailing list
Yxa-devel@lists.su.se
https://lists.su.se/mailman/listinfo/yxa-devel

Reply via email to