On Wed, 2009-10-21 at 23:11 +0200, Mikael Magnusson wrote:
> The dependency on m4/erlang-erts.m4, which is copyright FSF, could be
> removed but it means autoconf 2.64 is required instead.
> I may be able to change the license of m4/erlang-extra.m4.

Great, let me know.

> > 2) It doesn't work out of the (my) box. I get errors which I've tried to
> > sort out but m4/autoconf makes my head spin. Any help would be
> > appreciated.
> > 
> > YXA trunk, clean check out. Only patch 1/2 applied (also tried with
> > both). This is on Ubuntu Jaunty, which has autoconf 2.63-2ubuntu1.
> > 
> I'm resending the second patch. Maybe it was damaged somewhere between
> the list server and your email reader, because both patches applied
> cleanly on yxa trunk for me as received from the list server.

The patch applied clean, I just couldn't get the result to work =). I
guess it is because of the problems with Erlang support in autoconf 2.63
that you referred to.

> Erlang support is broken on autoconf 2.63, refer to
> http://erlang.org/pipermail/erlang-questions/2009-May/043838.html
> I guess more people will be hit by this. Do you see any problems with
> requiring autoconf 2.64? It's in Ubuntu 9.10 Karmic Koala released next
> week, and it should be possible to install the same package on 9.04.

Having autoconf >= 2.64 would only be a requirement for those generating
the configure script, not for everyone installing YXA, right? If so then
I see no problem at all... in a week or two when I myself have 2.64 ;)


Yxa-devel mailing list

Reply via email to