Hi Frank,

I just tried the same (just downloaded elasticsearch 5.4.1 and configured 
als usual). 

 -=> It just works fine. 

curl http://localhost:9200/

{

  "name" : "QQm2bUl",

  "cluster_name" : "elasticsearch",

  "cluster_uuid" : "MySiOtUjTeidMZgxoBY56Q",

  "version" : {

    "number" : "5.4.1",

    "build_hash" : "2cfe0df",

    "build_date" : "2017-05-29T16:05:51.443Z",

    "build_snapshot" : false,

    "lucene_version" : "6.5.1"

  },

  "tagline" : "You Know, for Search"

}


shell> rake searchindex:rebuild

drop indexes...

create indexes...

reload data...

 reload Organization

  - started at 2017-06-07 08:11:49 UTC

  - took 0 seconds

 reload Ticket

  - started at 2017-06-07 08:11:49 UTC

  - took 4 seconds

 reload User

  - started at 2017-06-07 08:11:54 UTC

  - took 0 seconds

Also search via web works fine! 

So I do not have an idea what's wrong on your setup. "Net::HTTPForbidden 
403 Forbidden" sounds like an proxy issue. I see you use different urls ("curl 
http://localhost:9200/"; and "Unable to process PUT at http://
127.0.0.1:9200/zammad_production")

Try to use also "Setting.set("es_url", "http://localhost:9200";)", but this 
is just an idea...

 -Martin


Am Dienstag, 6. Juni 2017 19:51:01 UTC+2 schrieb Frank Thommen:
>
> HI,
>
> when we search for keywords or tags in our zammad installation (1.5.0., 
> DEB repo installation) nothing happens.  That's probably because no index 
> is created.
>
> elasticsearch 5.4.1 has been installed as instructed on its webpage and 
> the functionality test works fine:
>
> $ curl http://localhost:9200/
> {
>   "name" : "ccQm79T",
>   "cluster_name" : "elasticsearch",
>   "cluster_uuid" : "ECRzkh-BT1WZuAAJfDncgA",
>   "version" : {
>     "number" : "5.4.1",
>     "build_hash" : "2cfe0df",
>     "build_date" : "2017-05-29T16:05:51.443Z",
>     "build_snapshot" : false,
>     "lucene_version" : "6.5.1"
>   },
>   "tagline" : "You Know, for Search"
> }
> $
>
>
>
> zammad has been configured as instructed on 
> https://docs.zammad.org/en/latest/install-elasticsearch.html.  The 
> optional steps have been skipped.
>
> However zammad run rake searchindex:rebuild --trace throws an error:
>
> $ zammad run rake searchindex:rebuild  --trace
> ** Invoke searchindex:rebuild (first_time)
> ** Invoke environment (first_time)
> ** Execute environment
> ** Execute searchindex:rebuild
> ** Execute searchindex:drop
> drop indexes...
> ** Execute searchindex:create
> create indexes...
> rake aborted!
> Unable to process PUT at http://127.0.0.1:9200/zammad_production
> #<UserAgent::Result:0x0055e795e93d38 @success=false, @body=nil, @data=nil, 
> @code="403", @content_type=nil, @error="Client Error: #<Net::HTTPForbidden 
> 403 Forbidden readbody=true>!">
> /opt/zammad/lib/search_index_backend.rb:62:in `index'
> /opt/zammad/lib/tasks/search_index_es.rake:19:in `block (2 levels) in <top 
> (required)>'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:248:in 
> `block in execute'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:243
> :in `each'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:243:in 
> `execute'
> /opt/zammad/lib/tasks/search_index_es.rake:60:in `block (2 levels) in <top 
> (required)>'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:248
> :in `block in execute'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:243:in 
> `each'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:243:in 
> `execute'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:187
> :in `block in invoke_with_call_chain'
> /opt/zammad/vendor/ruby-2.3.1/lib/ruby/2.3.0/monitor.rb:214:in `
> mon_synchronize'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:180:in 
> `invoke_with_call_chain'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/task.rb:173
> :in `invoke'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application.rb:152:in
>  
> `invoke_task'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application.rb:108:in
>  
> `block (2 levels) in top_level'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application
> .rb:108:in `each'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application.rb:108:in
>  
> `block in top_level'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application.rb:117:in
>  
> `run_with_threads'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application
> .rb:102:in `top_level'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application.rb:80:in
>  
> `block in run'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application.rb:178:in
>  
> `standard_exception_handling'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/lib/rake/application
> .rb:77:in `run'
> /opt/zammad/vendor/bundle/ruby/2.3.0/gems/rake-11.2.2/exe/rake:27:in `<top 
> (required)>'
> /opt/zammad/vendor/bundle/ruby/2.3.0/bin/rake:23:in `load'
> /opt/zammad/vendor/bundle/ruby/2.3.0/bin/rake:23:in `<main>'
> Tasks: TOP => searchindex:rebuild
> $
>
>
> Any hint, what could be the problem?
>
> Cheers
> frank
>
>

-- 
Open Source as Download https://zammad.org || Easy to use as SaaS 
https://zammad.com
--- 
You received this message because you are subscribed to the Google Groups 
"zammad-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to zammad-users+unsubscr...@googlegroups.com.
To post to this group, send email to zammad-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/zammad-users/0ec25233-a52c-40be-aeb7-e6fabdc81489%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to