Create a test ticket and do this:

# zammad run rails r "Setting.set('es_url', 'http://localhost:9200')"
# zammad run rails r "Setting.set('es_index', 'zammad')"
# zammad run rake searchindex:rebuild 

On Friday, November 17, 2017 at 3:54:51 AM UTC-5, Gunnar Maronde wrote:
>
> You are right, there was an error. The output is 
>
> drop indexes...
> create indexes...
> rake aborted!
> Unable to process PUT at http://localhost:9200/elrond_zammad_production
> #<UserAgent::Result:0x0055e68bb071e8 @success=false, @body=nil, @data=nil, 
> @code=0, @content_type=nil, @error="#<Errno::ECONNREFUSED: Failed to open 
> TCP connection to localhost:9200 (Connection refused - connect(2) for 
> \"localhost\" port 9200)>">
> /opt/zammad/lib/search_index_backend.rb:62:in `index'
> /opt/zammad/lib/tasks/search_index_es.rake:19:in `block (2 levels) in <top 
> (required)>'
> /opt/zammad/lib/tasks/search_index_es.rake:60:in `block (2 levels) in <top 
> (required)>'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.1.0/exe/rake:27:in `<top 
> (required)>'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli/exec.rb:74:in
>  
> `load'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli/exec.rb:74:in
>  
> `kernel_load'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli/exec.rb:27:in
>  
> `run'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli.rb:360:in
>  
> `exec'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor/command.rb:27:in
>  
> `run'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in
>  
> `invoke_command'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor.rb:369:in
>  
> `dispatch'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli.rb:20:in
>  
> `dispatch'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor/base.rb:444:in
>  
> `start'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli.rb:10:in
>  
> `start'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/exe/bundle:35:in 
> `block in <top (required)>'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/friendly_errors.rb:121:in
>  
> `with_friendly_errors'
> /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/exe/bundle:27:in 
> `<top (required)>'
> /opt/zammad/bin/bundle:3:in `load'
> /opt/zammad/bin/bundle:3:in `<main>'
> Tasks: TOP => searchindex:rebuild
> (See full trace by running task with --trace)
>
>
> Am Freitag, 17. November 2017 09:50:31 UTC+1 schrieb Martin Edenhofer:
>>
>> It seems hat the index is not existing in elastichsearch.
>>
>> What was the output of:
>>
>> zammad run rake searchindex:rebuild
>>
>>  -Martin
>>
>> Am Freitag, 17. November 2017 09:46:06 UTC+1 schrieb Gunnar Maronde:
>>>
>>> Thanks, I habe done it but now I get the follwing error message when 
>>> starting the reporting: 
>>>
>>> {"error":"Unable to process POST at 
>>> http://localhost:9200/elrond_zammad_production/Ticket/_search\n#\u003cUserAgent::Result:0x007fbd9c2e4328
>>>  
>>> @success=false, @body=nil, @data=nil, @code=\"404\", @content_type=nil, 
>>> @error=\"No such file 
>>> http://localhost:9200/elrond_zammad_production/Ticket/_search, 
>>> 404!\"\u003e"}
>>>
>>> Am Freitag, 17. November 2017 09:24:17 UTC+1 schrieb Martin Edenhofer:
>>>>
>>>> https://docs.zammad.org/en/latest/install-elasticsearch.html
>>>>
>>>> Enjoy,
>>>>
>>>>  -Martin
>>>>
>>>> Am Freitag, 17. November 2017 09:22:52 UTC+1 schrieb Gunnar Maronde:
>>>>>
>>>>> I just updated my zammad installation from Version 1.5 to 2.1 via 
>>>>> "apt-get install zammad". By doing that, elasticsearch was also 
>>>>> installed, 
>>>>> which I did not use before. When I try to open the Reporting in the Web 
>>>>> GUI, I get the message 
>>>>> Elasticsearch need to be configured! (see attached screenshot)
>>>>>
>>>>> What has to be done for the Configuration? I am running a Debian 8.9 
>>>>> jessie installation. 
>>>>>
>>>>

-- 
Open Source as Download https://zammad.org || Easy to use as SaaS 
https://zammad.com
--- 
You received this message because you are subscribed to the Google Groups 
"zammad-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to zammad-users+unsubscr...@googlegroups.com.
To post to this group, send email to zammad-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/zammad-users/03b851a8-c1ab-4d78-8b85-183c53202e31%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to