Hello,

I was now able to connect to our university WLAN one time with my Fiberline 
WL-430U USB dongle.  Alas, all the other times it didn't work.  What follows 
is a rather detailed description of some of my experiences.  I would be 
really happy if some of you would take the time, and read through this e-mail 
and provide me with some hints about how to solve the outstanding problems. 
Thank you in advance.

I plugged the USB WLAN dongle into the USB socket.  The kernel output a lot of 
messages.  The last messages were as follows:

        zd1211: Mixed Mode
        zd1211: AllowedChannel = 000007ff
        zd1211: LinkLEDn = 200
        AllowedChannel = 000107ff
        Region: 48
        zd1205: (exit) zd1205_config, /usr/src/zd1211-driver-r71/src/zd1205.c
                line 2597
        zd1205: (exit) zd1205_config, /usr/src/zd1211-driver-r71/src/zd1205.c
                line 8555

Is mixed mode okay?  Are the last two messages in any way problematic?

Now I entered iwlist wlan0 scan.  The output was:

        wlan0    Interface doesn't support scanning.

Why this?  Is this because the interface wasn't brought up yet with ifconfig 
wlan0 up?

Now I entered exactly this: ifconfig wlan0 up.  The kernel output this:

        zd1205: (enter) zd1205_open, /usr/src/zd1211-driver-r71/src/zd1205.c
                line 4348
        zd1205: (exit) zd1205_open, /usr/src/zd1211-driver-r71/src/zd1205.c
                line 4431
        ADDRCONF(NETDEV_UP): wlan0: link is not ready
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: Mixed Mode
        zd1211: STA_ASSOCIATED with 00:01:f4:5b:a6:3b
        ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

Why is the link not ready first?  Why are there so many “Mixed Mode” entries?  
In addition, I have to say that this was the only time I was ever able to get 
the wlan0 link ready.  In all the other cases, at least the last two of the 
above lines weren't present.

After that, I entered iwlist wlan0 scan.  The output was:

        wlan0    No scan results

Strange, as the WLAN link was established.  In some other cases, I got useful 
output, in this and also several other cases, I got only the above line.

Now I tried iwconfig wlan0.  The output showed me the correct ESSID, a 
frequency of 2.452 GHz, and the correct access point.  The mode was set to 
“Managed”.  The link quality was 92/100, the signal level 55/100, and the 
noise level 0/100.  Surprisingly, only 1 Mb/s was shown as the bitrate.

Is it normal that the ESSID, frequency and access point settings are made 
automatically?  On http://zd1211.ath.cx/ I'm told that I shall set the ESSID 
manually.

A following dhclient wlan0 and pinging one of the servers in the WLAN were 
successful.

During the above experiment, my laptop was not more than 5 metres away from 
the WLAN access point.  I moved two more metres away from it and back.  This 
resulted in a loss of the connection.  The frequency shown bei iwconfig was 
now a bit below the right value (don't remember the exact value).  The 
problem now is that I cannot change the frequency.  iwconfig wlan0 freq 
<value> as well as iwconfig wlan0 channel <value> always shows me the 
following:

        Error for wireless request "Set Frequency" (8B04) :
            SET failed on device wlan0 ; Invalid argument.

But I think, I used meaningful arguments.  For example, I entered iwconfig 
wlan0 channel 9.  What is the reason for this?

I tried to solve the problem by entering ifconfig wlan0 down, followed by 
ifconfig wlan0 up.  The link never became functional again.  Issuing iwconfig 
wlan0 multiple times showed me that the frequency was always changed.  Is 
this normal, e.g., the hardware searching for the right frequency, or is this 
a bug?  Unplugging and replugging the dongle (thereby obviously reloading the 
driver) also didn't solve the problem.

Later I had the situation that iwlist wlan0 scan worked, i.e., showed me the 
correct data about my WLAN.  Surprisingly, I was not able to establish a link 
but the problem of ever-changing frequencies occured.  Is this a bug in the 
driver?  Or a problem with the hardware?

I hope, you can help me, at least a bit.  Thank you for your efforts.

Best wishes,
Wolfgang


-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid0944&bid$1720&dat1642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to