> After an upgrade of my kernel to 2.6.16, I needed to recompile the ZD1211
> driver so I grabbed the latest version (r69).  Compiled and installed fine.
> Problem is, I can't seem to get any data traffic through.  I can associate
> fine with access points (and even see all available ones in iwlist), but
> when I try to do DHCP, I won't get a response.  If I set my IP manually and
> ping, no response.  I've tried to disable WEP, but still no response.
> I tried r54-testing, and it works fine (had to comment out the owner line
> since 2.6.16 doesn't have that field anymore).

In light of the recent changes I'm not sure if my knowledge on the driver is 
still up to par. Just one thing that catches my eye though:

This seems to be the result of using iwconfig as I know it:
> Here is dmesg from r54-testing:
> [4296001.978000] keybuf data [5]:
> [4296001.978000] 93 a6 75 f6 ad
> [4296001.983000] zd1211:WEP64 Mode
> [4296001.992000] Update CardSetting
> [4296001.992000] keybuf data [0]:
> [4296001.992000]
> [4296001.992000] Just Update WEP key

This seems to be the result of using wpa_supplicant as I know it:
(it uses different routines to configure encryption)
> and from r69:
> [4296707.951000] wlan0: Configured authentication algorithms:  Open system
> [4296708.035000] wlan0: Drop encrypted: enabled
> [4296708.035000] zd1211:Switch to Infra mode
> [4296708.035000] zd1211:Mixed Mode
> [4296708.036000] wlan0: WPA version:  WPA disabled
> [4296708.036000] wlan0: pairwise cipher:  WEP40
> [4296708.036000] wlan0: group cipher:  WEP40
> [4296708.037000] wlan0: key mgmt:  unsupported key mgmt '0x08'
> [4296708.037000] wlan0: privacy: disabled
> [4296708.037000] wlan0: Allow Rx unencrypted EAPOL: enabled

This seems to be triggered if the encryption parameters are mixed up somehow:
> [4296712.104000] chkpnt 001

This message might be the result of failing or incorrectly configured data 
packets. I think it has something to do with the differences in how 
encryption is set up.

Did you use the same tools (same versions) on both r54 and r69 to set up your 
wireless network ?

If something's wrong with setting up encryption then going from encrypted to 
unencrypted might not work. 

Does something like this work:
- load zd1211 module
- configure unencrypted network
- bring up interface
(not sure if the last two items need to be swapped)

This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to