Hello,

After hours of struggling with the zd1211b driver, switching to the
zd1211rw rewrite driver solved my connection problems.

Product:  Belkin Wireless G USB Network adapter v4000
How to get the product version:
   * look for a small sticker on the box the USB stick
     came in, it should show "ver. 4000"
   * identify product by USB ID (ie, use the lsusb command)
USB ID : 050d:705c Belkin Components
chip ID :  zd1211b chip 050d:705c v4810 high 00-17-3f AL2230_RF pa0 g--N
FCC ID : should still be F5D7050
tested distro: Ubuntu 6.10 Edgy
driver code version: 12-Nov-06 snapshot

Before this, I had problems with the zd1211b driver. The following
symptoms appeared, and I have seen them often reported in various
mailing lists, but nobody replied with a solution:
- driver zd1211b is installed correctly and a wlan0 device appears
- you can scan the network, bring the interface up, set an SSID
- you can see the network you want to connect to in the scan
- in iwconfig, you see "Access Point: Not-Associated", "Tx excessive
retries:210450" (a high number that augments linearly with the time
the interface is up)
- in dmesg, there are lines that state "zd1211: Mixed Mode" twice per second
- and, obviously, you are still not connected
==> the solution that worked for me: switch to the zd1211rw driver,
you may need to add your usb id to zd_usb.c before compiling the
driver (see http://zd1211.ath.cx/wiki/UntestedWithRewrite).

Thanks for the driver !

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to