Hi,
I'm trying to use a zd1211B based USB stick on my ARM9 board running
2.6.20-RC3 using the zd1211rw driver however it wont load the firmware.

I've enabled debugging - and got the following from dmesg:

[snip]

<7>DEV: registering device: ID = '1-3:1.0'
<7>bus usb: add device 1-3:1.0
<7>usb 1-3:1.0: uevent
<7>usb: Matched Device 1-3:1.0 with Driver zd1211rw
<7>usb: Probing driver zd1211rw with device 1-3:1.0
<7>zd1211rw 1-3:1.0: usb_probe_interface
<7>zd1211rw 1-3:1.0: usb_probe_interface - got id
<7>usb 1-3: print_id() 0ace:1215 v4810 full
<7>zd1211rw 1-3:1.0: zd_netdev_alloc() netdev->flags 0x1002
<7>zd1211rw 1-3:1.0: zd_netdev_alloc() netdev->features 0x00000000
<7>usb 1-3: request_fw_file() fw name zd1211b_ub
<7>DEV: registering device: ID = '1-3'
<7>dev_uevent - dev_uevent() returned -19
<7>DEV: Unregistering device. ID = '1-3'
<3>usb 1-3: Could not load firmware file zd1211b_ub. Error number -2
<3>zd1211rw 1-3:1.0: couldn't load firmware. Error number -2

[/snip]

I guess this is the interesting part of the dmesg:

<7>DEV: registering device: ID = '1-3'
<7>dev_uevent - dev_uevent() returned -19
<7>DEV: Unregistering device. ID = '1-3'
<3>usb 1-3: Could not load firmware file zd1211b_ub. Error number -2
<3>zd1211rw 1-3:1.0: couldn't load firmware. Error number -2

I've tried placing the firmware in:
./lib/firmware/zd1211/ and ./usr/lib/firmware/zd1211/ and
./usr/lib/hotplug/firmware/zd1211/ and ./lib/firmware/

# ls -la /lib/firmware/zd1211/
drwxr-xr-x    2 root     root         1024 Jan  5  2007 .
drwxr-xr-x    3 root     root         1024 Jan  5  2007 ..
-rw-r--r--    1 root     root          733 Jan  5  2007 README
-rw-r--r--    1 root     root         4018 Jan  5  2007 zd1211_ub
-rw-r--r--    1 root     root         5120 Jan  5  2007 zd1211_uph
-rw-r--r--    1 root     root         5120 Jan  5  2007 zd1211_uphm
-rw-r--r--    1 root     root         5120 Jan  5  2007 zd1211_uphr
-rw-r--r--    1 root     root         3584 Jan  5  2007 zd1211_ur
-rw-r--r--    1 root     root         4018 Jan  5  2007 zd1211b_ub
-rw-r--r--    1 root     root         5120 Jan  5  2007 zd1211b_uph
-rw-r--r--    1 root     root         5120 Jan  5  2007 zd1211b_uphm
-rw-r--r--    1 root     root         5120 Jan  5  2007 zd1211b_uphr
-rw-r--r--    1 root     root         3584 Jan  5  2007 zd1211b_ur

Anyone got a hint to what might be the problem?

Best regards
Nikolaj
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to