OK, Just a followup on this:

I got it working in the actual 2.6.20 of Ubuntu Feisty. What I did:

1. Installed linux-headers-2.6.20-xxx
2. Installed linux-source-2.6.20
3. Modified the zd1211rw to add my USB ID numbers.
4. Compiled the module with the following:

make -C /lib/modules/2.6.20-6-386/build M=`pwd` modules

(standing within the directory of the 2.6.20 zd1211rw module)

5. and voil?. The new zd1211rw.ko file that appeared in the directory
just works like a charm.

       Thanks for the info!
       diego.


Hi

This is what I am trying to do as well, but I can't resovel my problems.
Should be equally simple, but I am as I said very much a novice when it
comes to these things. I'll describe in detail my steps:
I have also installe the kernel headers, the restricted modules and the
2.6.20 source from apt get and run apt-get update - upgrade

I then downloaded the driver from yesterday unpacked it and entered that
directory.  I then tried to issu "make", but then got the previously
described errors. I also tried the command you wrote above  (except with
make -C /lib/modules/2.6.20-6-generic/build M=`pwd` modules) but that did
not work either. Could you give me a more step by step instruction please? I
mean - such as which directory have you placed the firmware in and which
exact version of the driver do you use. I might be forced to reinstall
feisty (no problem really since I do not use it except for testing because
of the wireless issue...). How do I know where the symlink should go btw?

Sorry for bothering you guys!

Best regards
Ketil Thorgersen
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to