Got one of these the other day. USB ID is 0ace:1215, but sadly it contains
the UW2453 RF device. So yet another device with the same USB ID but
different RF!

Started using it on Gentoo with Kernel 2.6.22-r9

Tried using the supplied linux drivers - couldn't get them to compile.
Tried the Vendor Drivers 2.21 and 2.22 - got them to compile but I'm using
the device through a USB1.1 port and while it would successfully upload the
firmware it stalled on "rebooting the device" (intr_urb: failed with error
-5). Tried to poke around the code but no luck.... 

So bit the bullet and installed 2.6.23-r3 and used the updated zd1211rw
driver with the UW2453 RF support and seem to have a degree of success.

But I'm getting fairly regular crashes, here's the log:

 ------------[ cut here ]------------
 kernel BUG at kernel/workqueue.c:220!
 invalid opcode: 0000 [#1]
 Modules linked in: zd1211rw
 CPU:    0
 EIP:    0060:[<c01249cb>]    Not tainted VLI
 EFLAGS: 00010002   (2.6.23-gentoo-r3 #3)
 EIP is at queue_delayed_work_on+0x1b/0x80
 eax: 00000000   ebx: ee20f544   ecx: ee20f534   edx: ef7ee8a0
 esi: ffffffff   edi: ee20f534   ebp: ee20f520   esp: c16e9f50
 ds: 007b   es: 007b   fs: 0000  gs: 0000  ss: 0068
 Process events/0 (pid: 5, ti=c16e8000 task=ef7d3570 task.ti=c16e8000)
 Stack: 00000296 ee6e5200 c0124a6c 00000bb8 c036ab81 00000000 00000000
 00000000 00000000 c050ec00 c036cb50 00000000 ed414b60 ef7ee880 ee20f534 
 c036ab30 00000000 c012447b c16e9fb4 00000046 ef7d3570 ef7ee880 ef7ee880 
 Call Trace:
 [<c0124a6c>] queue_delayed_work+0x1c/0x20
 [<c036ab81>] ieee80211softmac_auth_queue+0x51/0x130
 [<c036cb50>] ieee80211softmac_assoc_notify_auth+0x0/0x30
 [<c036ab30>] ieee80211softmac_auth_queue+0x0/0x130
 [<c012447b>] run_workqueue+0x6b/0xe0
 [<c0124ae0>] worker_thread+0x0/0xc0
 [<c0124b92>] worker_thread+0xb2/0xc0
 [<c0127080>] autoremove_wake_function+0x0/0x40
 [<c0126ef8>] kthread+0x38/0x60
 [<c0126ec0>] kthread+0x0/0x60
 [<c01040c7>] kernel_thread_helper+0x7/0x10

If the device is plugged in on boot up then it's ok,unless I stop and
restart it a few times. But it seems to cause most problems if I plug it in
after I've booted.

If I can be of any more help then let me know.

So thanks, keep up the good work, 

View this message in context:
Sent from the zd1211-devs mailing list archive at

SF.Net email is sponsored by: The Future of Linux Business White Paper
from Novell.  From the desktop to the data center, Linux is going
mainstream.  Let it simplify your IT future.
Zd1211-devs mailing list -

Reply via email to