OK I am waiting for Markus's reply.
Here is how i see it. More People use our code the more consultancy we can
provide even for proprietary. But I also agree on people respecting our work
:)

Code wise from stuff that is being used actively its only.

1. Seif
2. Natan
3. Siegfried
4. Mikkel
5. Markus
----------------------------
6. Alex (the focus stuff although not applied yet, so not sure if it counts)
7. KaKaRoTo (he send some fixes for LRU)

Cheers
Seif


2010/1/7 Siegfried Gevatter <rai...@ubuntu.com>

> Back to this, I thought I'd make sense to analyze what this means before
> we do any decision. Please correct me if there's anything I got wrong!
>
>
> -----------------------------------------------------------------------------------------------------------------
>
> CURRENT SITUATION (LGPLv3+)
>
> What can we do?
>  - We can copy code from files licensed under the LGPLv3+ or the LGPLv2.1+
> (note the "or later" on both of them).
>
> What can other do?
>  - They can copy code from Zeitgeist into files licensed under the GPLv3,
> GPLv3+, LGPLv3 or LGPLv3+. If they are using LGPLv2+, they can update to
> LGPLv3+ without needing the consent of all developers (as they have already
> given consent if it's "or later").
>  - They can use Zeitgeist, over D-Bus or using the Python module, no matter
> what license their software has (even proprietary).
>
> What advantages does it have?
>  - It has protection against DRM, ie. "tivoization" (good for the users).
>  - It has protection against patents.
>  - It has been updated to be more international, but GPLv2 has already won
> court cases, so this may not be that important.
>  - Maybe more stuff, I don't really know (but personally I trust the FSF's
> criteria defending version 3 over the 2).
>
> SITUATION WITH LGPLv2.1+
>
> What can we do?
>  - Copy code from LGPLv3+ and LGPLv2.1+.
>
> What can others do?
>  - They can copy code from Zeitgeist into files licensed under the GPLv2,
> GPLv2+, LGPLv2.1, LGPLv2.1+ GPLv3, GPLv3+, LGPLv3, LGPLv3+.
>  - They can use Zeitgeist, over D-Bus or using the Python module, no matter
> what license their software has (even proprietary).
>
> SUMMARIZING, THE CHANGES:
>
> What can we do?
>  - The same as before, we gain nothing changing the license.
>
> What can others do?
>  - They gain the possibility to copy code from Zeitgeist into files
> licensed under the GPLv2, the GPLv2+, the LGPLv2.1 or the LGPLv2.1+.
>
> Additionally, our users lose protection against DRM and also the patents
> chunk.
>
>
> -----------------------------------------------------------------------------------------------------------------
>
> Looking at this, I don't think we should switch, as by the switch we and
> our users are loosing the advantages GPLv3 gives, only to allow other
> people to copy code into {,L}GPLv2{,+} code. Myself, I'm writing the
> code for Zeitgeist, if others want to copy it they should respect my
> license and upgrade (also getting the advantages of version 3) if they
> really want (or, if they are interested in a chunk only I touched they
> may poke me and bribe me to give them that part under GPL2 because of a
> very good reason).
>
> --
> License change "LGPL 3" to "LGPL 2.1 or later"
> https://bugs.launchpad.net/bugs/499788
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
>
> Status in Zeitgeist Framework: New
>
> Bug description:
> There's a push to change the license of the codebase from "LGPL 3" to "LGPL
> 2.1 or later".
>
> As it stands we have full consent from Seif Lotfy and Mikkel Kamstrup.
> Siegfried Gevatter has made a conditional +1:
>
>  "If _everyone_ else wants to switch from "LGPL3 or later" to "LGPL 2.1or
> later", I'm fine with it."
>
> Of the core contributors Markus Korn has not answered yet.
>
> If Markus agrees the next logical step is to create a list of other
> contributors we have that should be heard.
>
>
>
>

-- 
License change "LGPL 3" to "LGPL 2.1 or later"
https://bugs.launchpad.net/bugs/499788
You received this bug notification because you are a member of Zeitgeist
Developers, which is the registrant for Zeitgeist Framework.

Status in Zeitgeist Framework: New

Bug description:
There's a push to change the license of the codebase from "LGPL 3" to "LGPL 2.1 
or later".

As it stands we have full consent from Seif Lotfy and Mikkel Kamstrup. 
Siegfried Gevatter has made a conditional +1:

  "If _everyone_ else wants to switch from "LGPL3 or later" to "LGPL 2.1or 
later", I'm fine with it."

Of the core contributors Markus Korn has not answered yet.

If Markus agrees the next logical step is to create a list of other 
contributors we have that should be heard.



_______________________________________________
Mailing list: https://launchpad.net/~zeitgeist
Post to     : zeitgeist@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zeitgeist
More help   : https://help.launchpad.net/ListHelp

Reply via email to