So the final consensus is that the parameter s is any randomly chosen
identifier for an application.

* GetBlacklists() -> ({sE})
* AddBlacklist(sE) --> Changed(sE)
* RemoveBlacklist(sE) --> Changed(sE)

I changed the name to Blacklist instead of Template for the method names
as it sounds better and is more clear

You received this bug notification because you are a member of Zeitgeist
Framework Team, which is subscribed to Zeitgeist Framework.

  Blacklist API sucks

Status in NULL Project:
Status in Unity Files Place:
Status in Zeitgeist Framework:

Bug description:
  Guys, GetBlacklist and SetBlacklist (without any signals) for an 
asynchrounous-by-nature API? Come on!

How about changing it to Get, Add, Remove and a changed signal? That way it'd 
be actually usable...

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to