The solution didn't help me. After the latest Synapse update, it stopped
locating a folder called 'systems' when I type 'systems' (the folder's
location is ~/Systems). Still doesn't find it after wiping and redoing
the index though. Could be another issue - I'm not sure, but is

You received this bug notification because you are a member of Zeitgeist
Extensions, which is the registrant for Zeitgeist Extensions.

  FTS index corruption

Status in Synapse:
Status in Zeitgeist Extensions:

Bug description:

  since a few days synapse does not show any folders anymore - of course
  I made sure that the directory plugin is enabled. I also disabled it,
  restarted synapse and enabled it again. It still did not work. The
  config.json file seems to be proper, too.

  Starting synapse from commandline, I get the following output each
  time I press any letter:

  ** (synapse:26138): WARNING **: zeitgeist-plugin.vala:574: Zeitgeist search 
failed: Remote Exception invoking org.gnome.zeitgeist.Index.Search() on 
/org/gnome/zeitgeist/index/activity at name org.gnome.zeitgeist.Engine: 
org.freedesktop.DBus.Python.xapian.DatabaseCorruptError: Traceback (most recent 
call last):
    File "/usr/lib/pymodules/python2.6/dbus/", line 702, in 
      retval = candidate_method(self, *args, **keywords)
    File "/usr/share/zeitgeist/_zeitgeist/engine/extensions/", line 123, 
in Search
      offset, count, result_type)
    File "/usr/share/zeitgeist/_zeitgeist/engine/extensions/", line 253, 
in search
  DatabaseCorruptError: Data ran out unexpectedly when reading posting list.
  ** (synapse:26138): DEBUG: zeitgeist-plugin.vala:580: ZG search took 19 ms
  SynapseHybridSearchPlugin found 0 extra uris (ZG returned 0)

  I've tested synapse, from your download section and I
  also tested the recent version from branch. The folders I tried to
  find were ordinary folders within the home-partition (like
  "Documents", "Music", "Desktop", "Videos").



Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to