Hey thansen,
I managed to get that environment variable in the build script somehow. The 
patch is attached
I still get the error that it is not compatible with Firefix 4.0

The solution was adding 
+            AC_DEFINE(MOZ_NO_MOZALLOC, ["For Mozilla Firefox 4"])

in configure.ac


Still not sure how to make it compatible with Firefox 4

** Patch added: "Updated patch for firefox dataprovider"
   
https://bugs.launchpad.net/zeitgeist-dataproviders/+bug/709103/+attachment/2097031/+files/updated-ffpatch.patch

-- 
You received this bug notification because you are a member of Zeitgeist
Framework Team, which is subscribed to Zeitgeist Data-Sources.
https://bugs.launchpad.net/bugs/709103

Title:
  Firefox extension doesn't work with FF4

Status in Zeitgeist Data-Providers:
  Confirmed

Bug description:
  When installed and up it shows alert box
  "TypeError: 
Components.classes['@zeitgeist-project.com/DATAPROVIDER/firefox-xpcom;1'] is 
undefined"
  and does so every time new window is opened.

  Also previous FF4 betas were affected.

_______________________________________________
Mailing list: https://launchpad.net/~zeitgeist
Post to     : zeitgeist@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zeitgeist
More help   : https://help.launchpad.net/ListHelp

Reply via email to