My attempts to start Zekr haven't been working. This is a relatively
new install, so I don't know when/if it last worked.

OS: Archlinux
Firefox: 6
FIREFOX_FIVE_HOME: /usr/lib/firefox-6.0
xulrunner --version: Mozilla XULRunner 6.0 - 20110816191201

Any suggestions? I was trying to get this to open in Eclipse, and it
would keep dying when I tried to step over line 475 in
[quranBrowser = new Browser(sashForm, getBrowserStyle());].

Excerpt from hs_err_pid log file:
Stack: [0xb6bc3000,0xb6c14000],  sp=0xb6c11c30,  free space=315k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code,
C=native code)
C  []  NS_UTF16ToCString_P+0x1dae0

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  org.eclipse.swt.internal.mozilla.XPCOM._NS_NewLocalFile(II[I)I+0
j  org.eclipse.swt.internal.mozilla.XPCOM.NS_NewLocalFile(II[I)I+10
j  org.eclipse.swt.browser.AppFileLocProvider.<init>(Ljava/lang/
j  org.eclipse.swt.browser.Mozilla.create(Lorg/eclipse/swt/widgets/
j  org.eclipse.swt.browser.Browser.<init>(Lorg/eclipse/swt/widgets/
j  net.sf.zekr.ui.QuranForm.makeFrame()V+529
j  net.sf.zekr.ui.QuranForm.init()V+280
j  net.sf.zekr.ui.QuranForm.<init>(Lorg/eclipse/swt/widgets/Display;)V
j  net.sf.zekr.ZekrMain.startZekr()V+119
j  net.sf.zekr.ZekrMain.main([Ljava/lang/String;)V+7
v  ~StubRoutines::call_stub

I have tried this with both Firefox 5 and Firefox 6, with jre6 and
jre7. I have also tried downloading a new swt.jar file.

How can I get Zekr working?


You received this message because you are subscribed to the Google Groups 
"zekr" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to