Hi,

I am struggling with ZFS/ACL on indiana preview. (ps: I am new to ZFS, 
new to indiana, and generally incompetent on Solaris admin commands:-)

First of, I am a bit surprised the 'old' setfacl command does not work 
on ZFS:

setfacl -m user:ludo:rw- /etc/apache2/2.2/httpd.conf
File system doesn't support aclent_t style ACL's.
See acl(5) for more information on ACL styles support by Solaris.


So I try the chmod (based on google search 
http://www.cims.nyu.edu/cgi-comment/man.cgi?section=1&topic=chmod
or http://blogs.sun.com/lisaweek )

I do:
chmod A+user:ludo:read_data:rwx php.ini
chmod: invalid mode: `A+user:ludo:read_data:rwx'
Try `chmod --help' for more information.

or
chmod A+user:ludo:read_data:allow php.ini
chmod: invalid mode: `A+user:ludo:read_data:allow'
Try `chmod --help' for more information.

or:
ls -v php.ini

ls -v php.ini
php.ini

(note the lack of ACL info displayed there)

Then

man chmod

Miscellaneous                                          missing(x)
    missing - Missing Manual Page
DESCRIPTION
    Unfortunately, this OpenSolaris Developer Preview  does  not
    include  the  manual  page you are looking for.  We're sorry
    and hope to improve upon this situation in future releases.
    Online versions  of  many  manual  pages  are  available  at
    http://docs.sun.com/app/docs/coll/40.17.

SunOS 5.11            Last change: 07/10/25                     1


I try to understand how people would react to this incompatible setfacl 
command on an indiana system with zfs :

How would you write a script  to change acl for a user  for both zfs and 
non zfs system (i.e SXDE default installation or Indiana default 
installation): 
https://www.phillconrad.org/cisc474/Wiki.jsp?page=AccessControlLists)
What is the good way for doing this?

So how can I write a portable script (with or without zfs) that would 
take a user name as a parameter and would add rwx rights to the file /foo?

Why setfacl could not be adapted to work on ZFS, as if I am guessing 
correctly, there should be a simple mapping from the limited setfacl 
options to the mega-extended chmod options for ZFS?

Thanks for some pointers or some help,
Ludo

_______________________________________________
zfs-discuss mailing list
zfs-discuss@opensolaris.org
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

Reply via email to