Hi all,

I'm running FreeNAS 7 (based on FreeBSD 7.2) and using ZFS v.13. I had two 2TB 
drives and one 1TB drive in a raidz1. I recently bought another 2TB drive to 
replace the 1TB drive. Unfortunately, I ran into some serious issues which are 
described in the steps that I did below:

First, I scrubbed the disks and found no errors. Next I turned off the 
computer, unplugged the 1TB drive and plugged in the new 2TB drive into the 
same SATA port. I turned on the machine, and executed 'zpool status'. The 
system hung and ignored all interrupt and kill signals, and terminated any 
shutdown sequence, so I hard-shutdown the machine. Next I unplugged the new 2TB 
drive and plugged in the old 1TB drive. When I enter 'zpool status' I see that 
the pool is UNAVAIL and the vdev is CORRUPTED, and all three drives are online. 
I tried to export & import the pool, but was unable to import as there 'are not 
enough redundant copies of the data.'

It seems quite likely that all of the data is intact, and that something 
different is preventing me from accessing the pool. What can I do to recover 
the pool? I have downloaded the Solaris 11 express livecd if that would be of 
any use.

Thanks in advance,
zfs-discuss mailing list

Reply via email to