I would like to pick the brains of the ZFS experts on this list: What
would you do next to try and recover this zfs pool?

I have a ZFS RAIDZ1 pool named bank0 that I cannot import.  It was
composed of 4 1.5 TiB disks.  One disk is totally dead.  Another had
SMART errors, but using GNU ddrescue I was able to copy all the data
off successfully.

I have copied all 3 remaining disks as images using dd on to another
another filesystem.  Using the loopback filesystem I can treat these
images as if they were real disks.  I've made a snapshot of the
filesystem the disk images are on so that I can try things and
rollback the changes if needed.

"gir" is the computer these disks are hosted on.  It used to be a
Nexenta server, but is now Ubuntu 11.10 with the zfs on linux modules.

I have tried booting up Solaris Express 11 Live CD and doing "zpool
import -fFX bank0" which ran for ~6 hours and put out: "one or more
devices is currently unavailable"

I have tried "zpool import -fFX bank0" on linux with the same results.

I have tried moving the drives back into the controller config they
where before, and booted my old Nexenta root disk where the
/etc/zfs/zpool.cache still had an entry for bank0.  I was not able to
get the filesystems mounts. I can't remember what errors I got.  I can
do it again if the errors might be useful.

Here is the output of the different utils:

root@gir:/bank3/hd# zpool import -d devs
  pool: bank0
    id: 3936305481264476979
 state: FAULTED
status: The pool was last accessed by another system.
action: The pool cannot be imported due to damaged devices or data.
        The pool may be active on another system, but can be imported using
        the '-f' flag.
   see: http://www.sun.com/msg/ZFS-8000-EY

        bank0          FAULTED  corrupted data
          raidz1-0     DEGRADED
            loop0      ONLINE
            loop1      ONLINE
            loop2      ONLINE
            c10t2d0p0  UNAVAIL

root@gir:/bank3/hd# zpool import -d devs bank0
cannot import 'bank0': pool may be in use from other system, it was
last accessed by gir (hostid: 0xa1767) on Mon Oct 24 15:50:23 2011
use '-f' to import anyway

root@gir:/bank3/hd# zpool import -f -d devs bank0
cannot import 'bank0': I/O error
        Destroy and re-create the pool from
        a backup source.

root@gir:/bank3/hd# zdb -e -p devs bank0
Configuration for import:
        vdev_children: 1
        version: 26
        pool_guid: 3936305481264476979
        name: 'bank0'
        state: 0
        hostid: 661351
        hostname: 'gir'
            type: 'root'
            id: 0
            guid: 3936305481264476979
                type: 'raidz'
                id: 0
                guid: 10967243523656644777
                nparity: 1
                metaslab_array: 23
                metaslab_shift: 35
                ashift: 9
                asize: 6001161928704
                is_log: 0
                create_txg: 4
                    type: 'disk'
                    id: 0
                    guid: 13554115250875315903
                    phys_path: '/pci@0,0/pci1002,4391@11/disk@3,0:q'
                    whole_disk: 0
                    DTL: 57
                    create_txg: 4
                    path: '/bank3/hd/devs/loop0'
                    type: 'disk'
                    id: 1
                    guid: 17894226827518944093
                    phys_path: '/pci@0,0/pci1002,4391@11/disk@0,0:q'
                    whole_disk: 0
                    DTL: 62
                    create_txg: 4
                    path: '/bank3/hd/devs/loop1'
                    type: 'disk'
                    id: 2
                    guid: 9087312107742869669
                    phys_path: '/pci@0,0/pci1002,4391@11/disk@1,0:q'
                    whole_disk: 0
                    DTL: 61
                    create_txg: 4
                    faulted: 1
                    aux_state: 'err_exceeded'
                    path: '/bank3/hd/devs/loop2'
                    type: 'disk'
                    id: 3
                    guid: 13297176051223822304
                    path: '/dev/dsk/c10t2d0p0'
                    phys_path: '/pci@0,0/pci1002,4391@11/disk@2,0:q'
                    whole_disk: 0
                    DTL: 60
                    create_txg: 4

zdb: can't open 'bank0': No such file or directory
zfs-discuss mailing list

Reply via email to