On 05/16/2012 10:17 AM, Koopmann, Jan-Peter wrote:
>> One thing came up while trying this - I'm on a text install
>> image system, so my / is a ramdisk. Any ideas how I can change
>> the sd.conf on the USB disk or reload the driver configuration on
>> the fly? I tried looking for the file on the USB drive, but it
>> isn't in the rootfs (perhaps it's tucked away in some compressed
>> filesystem image). Thanks!
> I am by no means a Solaris or OI guru and live from good advice of
> other people and Mr. Google. So sorry. I have no clueŠ

I got lucky at Googling after all and found the relevant command:

# update_drv -vf sd

The PERC H200 card had nothing to do with it, it was all in the crappy
firmware in the HDDs. Simply adding

sd-config-list = "WD      WD3001BKHG","power-condition:false";

to my /kernel/drv/sd.conf (as you suggested) and reloading the driver
using update_drv solved it and I could then proceed with the
installation. The installer was even smart enough to install the
customized sd.conf into the new system, so no further tuning was

Thanks for the pointers, you saved my bacon.

zfs-discuss mailing list

Reply via email to