Gregg Wonderly <> wrote:
> Have you tried importing the pool with that drive completely unplugged?  

Thanks for your reply.   I just tried that.  zpool import now says:

   pool: d
     id: 13178956075737687211
  state: FAULTED
 status: The pool metadata is corrupted.
 action: The pool cannot be imported due to damaged devices or data.
        The pool may be active on another system, but can be imported using
        the '-f' flag.

        d                        FAULTED  corrupted data
          raidz1-0               FAULTED  corrupted data
            da1                  ONLINE
            3419704811362497180  OFFLINE
            da2                  ONLINE
            da3                  ONLINE
            da4                  ONLINE

Notice that in the absence of the faulted da2 the OS has assigned da3 to da2 
etc.  I suspect this was part of the original problem in creating a label with 
two da2s

zdb still reports that the label has two da2 children:

        type: 'raidz'
        id: 0
        guid: 11828532517066189487
        nparity: 1
        metaslab_array: 23
        metaslab_shift: 36
        ashift: 9
        asize: 9999920660480
        is_log: 0
            type: 'disk'
            id: 0
            guid: 13697627234083630557
            path: '/dev/da1'
            whole_disk: 0
            DTL: 78
            type: 'disk'
            id: 1
            guid: 3419704811362497180
            path: '/dev/da2'
            whole_disk: 0
            DTL: 71
            offline: 1
            type: 'disk'
            id: 2
            guid: 6790266178760006782
            path: '/dev/da2'
            whole_disk: 0
            DTL: 77
            type: 'disk'
            id: 3
            guid: 2883571222332651955
            path: '/dev/da3'
            whole_disk: 0
            DTL: 76
            type: 'disk'
            id: 4
            guid: 16640597255468768296
            path: '/dev/da4'
            whole_disk: 0
            DTL: 75

> Which HBA are you using?  How many of these disks are on same or separate 
> HBAs?

all the disks are on the same HBA

twa0: <3ware 9000 series Storage Controller>
twa0: INFO: (0x15: 0x1300): Controller details:: Model 9500S-8, 8 ports, 
Firmware FE9X
da0 at twa0 bus 0 scbus0 target 0 lun 0
da1 at twa0 bus 0 scbus0 target 1 lun 0
da2 at twa0 bus 0 scbus0 target 2 lun 0
da3 at twa0 bus 0 scbus0 target 3 lun 0
da4 at twa0 bus 0 scbus0 target 4 lun 0


zfs-discuss mailing list

Reply via email to