Thanks, Jason. I have found the problem. We were setting va_dirlinkcount 
equal to vap->va_nlink. However, va_dirlinkcount is actually supposed to be 
the count of directory hard links. When a file system does not support 
directory hard links, this value must be set to 1 or you just have to say 
you don't support  

ATTR_DIR_LINKCOUNT at all. I'll commit the fix shortly.
On Saturday, December 21, 2013 7:06:37 AM UTC-8, jasonbelec wrote:
>
> Both have been working of late, as has copying, rsync, snapshot, 
> send/receive, as well as copying from Finder then trashing to free up 
> space, recopying and trashing again to move stuff around various pools. As 
> you know I had pretty much zero success previous to our chatting things 
> through. I'm even happy with speed right now as I've been rebuilding the 
> massive media library on the new pool tech.
>
>
> --
> Jason Belec
> Sent from my iPad
>
> On Dec 21, 2013, at 7:16 AM, ilov...@icloud.com <javascript:> wrote:
>
> Jason, were you deleting with the Trash or rm?
>
> Also, as I noted noted in the new issue 
> https://github.com/zfs-osx/zfs/issues/110 the trash appears to have been 
> emptied after an export and import.
>
> On Saturday, December 21, 2013 4:11:24 AM UTC-8, jasonbelec wrote:
>>
>> Interesting, my recent builds have been deleting just fine on newly 
>> created pools. It was a huge issue a few weeks back and iLoveZFS and talked 
>> back and forth with the resulting build working perfectly. That said I’ll 
>> have to rebuild and retest when home from the holidays. 
>>
>>
>> -- 
>> Jason Belec 
>> Sent from my iPad 
>>
>> > On Dec 21, 2013, at 6:20 AM, Alex Blewitt <alex.b...@gmail.com> wrote: 
>> > 
>> >> On 21 Dec 2013, at 10:12, ilov...@icloud.com wrote: 
>> >> 
>> >> New issue opened 
>> >> 
>> >> https://github.com/zfs-osx/zfs/issues/110 
>> > 
>> > 
>> > Here was the fix from last time: 
>> > 
>> > 
>> https://github.com/alblue/mac-zfs/commit/613276b9c2e874eecbee8223d1c957a58f7ee779
>>  
>> > 
>> > Alex 
>> > 
>> > -- 
>> > 
>> > --- 
>> > You received this message because you are subscribed to the Google 
>> Groups "zfs-macos" group. 
>> > To unsubscribe from this group and stop receiving emails from it, send 
>> an email to zfs-macos+...@googlegroups.com. 
>> > For more options, visit https://groups.google.com/groups/opt_out. 
>>
>  -- 
>  
> --- 
> You received this message because you are subscribed to the Google Groups 
> "zfs-macos" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to zfs-macos+...@googlegroups.com <javascript:>.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>

-- 

--- 
You received this message because you are subscribed to the Google Groups 
"zfs-macos" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to zfs-macos+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to