Dear all,

I would like to do a quick poll on the minimum version of Gtk+ we need to
support.

Currently we try to stay compatible with gtk+ >= 2.6. However in newer Gtk
versions there are quite some useful features I would like to use without
also doing my own hacks for backward compatibility. Examples include the
text buffer serialization and tooltip frameworks  introduced in 2.10, and
the textentry icons introduced in 2.16.

I see following available:
Ubuntu:    2.22 (maverick), 2.12 (Lucid - LST)
Windows: 2.22 (installer from http://www.pygtk.org and this is the version
used in the zim installer)
Mac:        2.24 (http://www.macports.org/)

So looks to me that we can bump requirement at least to 2.12, although I
would be more happy to go all the way to 2.22.

My poll questions for you:
1/ Anybody using Gtk < 2.12 with no possible to update ?
2/ Anybody staying on Lucid untill the next LST ?

Regards,

Jaap
_______________________________________________
Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp

Reply via email to