Sorry that it took me a few days to run the debug of Zim .54. Below, you will 
find the information. I hope that it helps diagnose the issue that I'm having 
with Zim .54 on Vista 32bit. Thanks for your help.

zimdebug begins:
============
WARNING: Trashing of files not supported, could not import 'gio'
INFO: This is zim 0.54
DEBUG: Python version is sys.version_info(major=2, minor=7, micro=2, 
releaselevel='final', serial=0)
DEBUG: Platform is nt
DEBUG: Zim revision is:
  branch: zim-054-win
  revision: 469 sn...@glump.net-20120116060503-34c9lqg1jcd6kc0q
  date: 2012-01-16 01:05:03 -0500
DEBUG: Running from a source dir: 
H:\computers\ZimDesktopWikiPortable\App\ZimDesktopWiki
DEBUG: Set XDG_DATA_HOME to C:\Users\Me\.local\share
DEBUG: Set XDG_DATA_DIRS to [<Dir: H:\usr\share>, <Dir: H:\usr\local\share>]
DEBUG: Set XDG_CONFIG_HOME to C:\Users\Me\.config
DEBUG: Set XDG_CONFIG_DIRS to [<Dir: H:\etc\xdg>]
DEBUG: Set XDG_CACHE_HOME to C:\Users\Me\.cache
DEBUG: Running command: gui
DEBUG: Loading C:\Users\Me\Dropbox\steve-zim\notebook.zim
DEBUG: Loading C:\Users\Me\Dropbox\todo-zim\notebook.zim
DEBUG: Wrote C:\Users\Me\.config\zim\notebooks.list
Traceback (most recent call last):
  File "zim.py", line 66, in <module>
  File "zim\__init__.pyo", line 409, in main
  File "zim\gui\__init__.pyo", line 18, in <module>
  File "gtk\__init__.pyo", line 40, in <module>
  File "gtk\_gtk.pyo", line 12, in <module>
  File "gtk\_gtk.pyo", line 10, in __load
ImportError: DLL load failed: The specified procedure could not be found.
===========
zimdebug ends:
 
----------------------------
| Steve Daley              |
| mowest...@yahoo.com      |
----------------------------


________________________________
 From: Brendan Kidwell <sn...@glump.net>
To: mowestusa <mowest...@yahoo.com> 
Cc: Zim-wiki Launchpad Mailing List <zim-wiki@lists.launchpad.net> 
Sent: Tuesday, January 24, 2012 7:41 PM
Subject: Re: [Zim-wiki] Zim .54 on Windows Vista Doesn't Start
 

All: Can anyone else confirm this is a wide-spread problem with Vista? (Can 
anyone provide a smallest possible Vista virtual machine I can keep for 
testing? I hate building Windows VMs...)
 
Steve: If you don't mind, can you please try it again and provide the log file? 
I suspect whatever is wrong will happen just the same if you run the PORTABLE 
build of Zim 0.54, so you don't have to uninstall Zim 0.53. You can also do a 
regular install, but specify that you want to install to an alternate location 
and choose not to create any shortcuts or shell integration.
 
Once you have portable or desktop Zim 0.54 installed, please do the following 
and share with us what you get in the log file:
 
1. Go to this page < http://pastebin.com/73jNJ933 > and save the script I put 
there as 'zimdebug.cmd' on your desktop.
 
2. Move or copy the saved file to the program folder where you installed Zim 
0.54. If you used the Portable install, be sure to put it in the folder with 
zim.exe in it, which would be "[Apps 
folder]\ZimDesktopWikiPortable\App\ZimDesktopWiki".
 
3. Run 'zimdebug.cmd' by launching it from Windows Explorer in the folder where 
'zim.exe' is. Hopefully you'll get some debug output that you can copy and 
paste here.
 
Thanks for your help.
 
Brendan Kidwell

 
On Tue, Jan 24, 2012 at 5:45 PM, mowestusa <mowest...@yahoo.com> wrote:

Perhaps, I missed some extra dependency, but I have been running Zim .53 on 
Windows Vista without any issues (besides the known bugs which .54 addressed). 
Today, I installed and then tried to start Zim, but nothing came up, nothing 
happened. Zim was not even listed in the Task Manager as a running process.
>
>
>1. I tried an clean uninstall, then reinstall, still nothing.
>2. Tried a reinstall with a reboot, still nothing.
>3. Clean uninstall of .54 and reinstalled .53 and started up without issue.
_______________________________________________
Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp

Reply via email to