As far as Zim 0.60 is concerned I didn't tried it but as I know it uses
different API for plugins so it is unlikely that you can launch the plugin
in 0.60.

In case of Linux Mint you should use another directory for plugin and icon:
'/usr/share/zim/plugins' and '/usr/share/zim/pixmaps' (and there is no need
to change line-endings in the plugin file).
So I tried to launch the plugin on Linux Mint 17 (Zim 0.63 from ppa) and it
worked.

By the way, there is a new version available.

Regards, Pl


2015-09-05 9:21 GMT+04:00 JP Vossen <j...@jpsdomain.org>:

> I can't get this working on Linux Mint 17 using either Zim 0.60 (stock)
> or 0.63 (from PPA).
>
> /usr/share/pyshared/zim/plugins$ ll
> ...
> -rw-r--r-- 1 root root 4.3K Jun 14 15:17 backlinkpane.py
> drwxr-xr-x 2 root root 4.0K Sep  5 00:51 base/
> -rw-r--r-- 1 root root 8.9K Sep  2 10:22 bookmarksbar.py
> -rw-r--r-- 1 root root  16K Jun 14 15:17 calendar.py
> ...
>
> /usr/share/zim/pixmaps$ ll
> total 48K
> -rw-r--r-- 1 root root 1.6K Sep  2 10:22 add-bookmark.png
> -rw-r--r-- 1 root root  978 Jun 14 15:17 attachment.png
> -rw-r--r-- 1 root root  648 Jun 14 15:17 calendar.png
> ...
>
> I see nothing using in `zim -V` or `zim -D` output.  I do not see the
> plugin in "Zim > Edit > Preferences > Plugins" nor do I see any changes
> to the toolbar.
>
> I did notice that the "bookmarksbar.py" file I downloaded had CRLF
> line-endings and I know that makes Perl barf, so I converted the file to
> LF only, but no change.
>
> Clues?
>
>
_______________________________________________
Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp

Reply via email to