Hi Agustin,

Short answer: It's a design bug. :(

Short workaround: Copy both the page text that contains the images as well as the page's attachments to the new location.

Longer, technical answer:

This stems from the fact that images are embedded as special links to attached files (use Tools -> Edit Source to see that). Copy'n'pasting "the image" AFAIA only copies the link to the image. Now there are a few issues related to that:

1. If the link is relative (it usually is), then that link points to
   the wrong place in the new page.
2. The actual file is not copied, so if you move or delete the file in
   the original page later (or rename the original page itself), it's
   gone in the new page, too.

IMHO this should be fixed by teaching ZIM to differentiate between "attachment/embedded"-type links like local images, files, or equations and "reference"-type links like remote files and anything else. Also: Can we unify the way we link to attachments vs pages (where very similar issues arise, and have partially been fixed)?

Related bugs:
https://bugs.launchpad.net/zim/+bug/1086343
https://bugs.launchpad.net/zim/+bug/330320

Best, Steffen

On 17-Feb-17 12:00, Agustin Lobo wrote:
Why can't I copy pictures from one zim page and paste to another?
Thanks


_______________________________________________
Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp

Reply via email to