I am using Windows 8.1 64-bit and this issue has been an annoyance for as
long as I can remember (at least 2 years) throughout multiple Zim
releases.

I've installed a visual clipboard viewer, "Free Clipboard Viewer 3.0" which
immediately shows the clipboard contents whenever something is copied.
I'll run the program, then highlight something in zim and attempt a copy
with "Ctrl+C".  When something is successfully copied, the viewer will show
something like the attached "ok.png".  When something is not copied, I'll
see something like "bad.png".  I can highlight some text in zim and hit
"Ctrl+C" repeatedly and see the contents of the clipboard contain nothing
somewhere between 30-50% of copy attempts.

I would be happy to help troubleshoot further since the problem is very
reliably reproducible on my environment.

Thanks,

On Sun, Apr 23, 2017 at 5:18 PM, Marcio Tibirica <marcio.tibir...@gmx.com>
wrote:

> This seems to be a HUGE problem that can put in risk the future of Zim on
> the windows platform. Does anyone know if all Zim users in 64-bit Windows
> environment are having the same problem?
>
> mtibbi
> ===========
>
>
> Em 23/04/2017 00:40, Brendan Kidwell escreveu:
>
>> This isn't definitive evidence, but the only Windows that I've used Zim
>> with for years has been Windows 8.1 64-bit and Windows 7 64-bit. At
>> least once per week I get bit by the copy-didn't-do-anything bug or some
>> other clipboard exception. I can't provide a list of steps to reproduce
>> and I can't come up with any ideas for how to make the problem go away.
>>
>> I will continue to act as the maintainer the Windows build of Zim with
>> the most recent release of GTK 2 each time, but honestly this is the
>> main reason I've moved by work diary out of Zim and into PiggyDB. (I am
>> required to use Windows 7 64-bt for my job.)
>>
>> Any help in fixing this would be appreciated. I know next to nothing
>> about GTK 2 and I am not going to be the person who solves it.
>>
>>
>> On Sat, Apr 22, 2017, at 14:15, Marcio Tibiriçá wrote:
>>
>>> Hi Udo,
>>>
>>> Your case is really weird. Maybe something related to 64-bit core?
>>> I have used Zim in both Win7 and Win10 without having problems with
>>> copy and paste to other applications. But in my case both machines are
>>> 32-bit.
>>> Maybe somebody else running Zim on Win 64-bit can bring some clue on
>>> your issue.
>>>
>>> mtibbi
>>>
>>
>>
>>
>> _______________________________________________
>> Mailing list: https://launchpad.net/~zim-wiki
>> Post to     : zim-wiki@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~zim-wiki
>> More help   : https://help.launchpad.net/ListHelp
>>
>>
> _______________________________________________
> Mailing list: https://launchpad.net/~zim-wiki
> Post to     : zim-wiki@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~zim-wiki
> More help   : https://help.launchpad.net/ListHelp
>



-- 
Steve Chadsey <schad...@gmail.com>
_______________________________________________
Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp

Reply via email to