Hi all,
Houston, we've got big a problem !

Here is the traceback in ZEO_EVENTS.log:
"
------
2005-06-02T11:45:21 INFO(0) zrpc-conn:193.49.250.194:37684 zeoLoad() raised 
exception: 968647571
Traceback (innermost last):
 File /data/ZeoCVS/lib/python/ZEO/zrpc/connection.py, line 234, in 
handle_request
 File /data/ZeoCVS/lib/python/ZEO/StorageServer.py, line 337, in zeoLoad
 File /data/ZeoCVS/lib/python/ZODB/FileStorage.py, line 694, in 
modifiedInVersion
   (Object: /data/ZeoCVS/var/Data.fs)
CorruptedDataError: 968647571
"

And I can't pack the zodb, when I pack I've got this traceback :
"
------
2005-06-02T08:48:17 ERROR(200) zrpc:1193 Error raised in delayed method
Traceback (innermost last):
 File /data/ZeoCVS/lib/python/ZEO/StorageServer.py, line 865, in run
 File /data/ZeoCVS/lib/python/ZEO/StorageServer.py, line 402, in pack_impl
 File /data/ZeoCVS/lib/python/ZODB/FileStorage.py, line 1503, in pack
   (Object: /data/ZeoCVS/var/Data.fs)
 File /data/ZeoCVS/lib/python/ZODB/fspack.py, line 680, in pack
 File /data/ZeoCVS/lib/python/ZODB/fspack.py, line 464, in findReachable
 File /data/ZeoCVS/lib/python/ZODB/fspack.py, line 478, in buildPackIndex
 File /data/ZeoCVS/lib/python/ZODB/fspack.py, line 180, in checkTxn
 File /data/ZeoCVS/lib/python/ZODB/fspack.py, line 170, in fail
CorruptedError: /data/ZeoCVS/var/Data.fs:968633329:invalid transaction status: 
'g'
"

I run  Zope 2.6.2 , ZEO 2 and ZODB 3.1

I have tried to do a fsrecover, it removes a transaction. Then when I tried to 
lunch a pack, I've got a very strange error about unpickling :
"Error unpickling, ((UBTrees._IIBTreeqUIIBucketqtqNt.((J 
KJQKJyWKJ}WKJ06KJKJKJKJKKJKKJKKJ 
KKJKKJKKJKKJ8KJS 
KJ!KJGF*KJ%D.KJ.KJ.KJ.KJ;w/KJ>w/KJ?w/KJ~G0KJο1KJ3KJ'^7KJ;KJ;KJw<KJz<KJ{<KJ>KJ#IGKJPLGKJ|IKJJKKJMKJ
 ]KJ ]KJ ]KJ ]KJ ]KJ ]KJ ]KJ ]KJ 
]KJrdKJdKJdKJgKJgKJ]yKJozKJ|KJ|KJ|KJ 
|KJ}KJ}KJ}KJ}KJCKJIσKJJσKJdKJfKJ#[KJKJMKJNִ
 KJ״ KJڴ KJ۴ KJC) KJ KJئ KJ KJ KJD KJD KJ 
KJ$R KJIr| KJ KJ$ 
KJ}KJMKJKJKJKJKJKJ59KJ<9KJKJ/hK"
!!!!
I try to copyTransaction in a new Storage but it failed too.
This is a production site.
My last backup which is not corrupted date of Sunday morning !
I have mount my zodb on a Zope2.7.6 and I'm working on this release to solve my 
problem.

fstest say all is ok.
fsrefs say that :
"
oid 0x37d8e5 BTrees._IIBTree.IIBTree
last updated: 2005-05-28 15:48:11.159195, tid=0x35D95942F9CD111L
refers to invalid object:
       oid 0x5d4787 missing: 'BTrees._IIBTree.IIBucket'

oid 0x37d8ec BTrees._IOBTree.IOBucket
last updated: 2005-05-07 00:56:12.524043, tid=0x35D1BF8356F9844L
refers to invalid object:
       oid 0x39c22b missing: 'BTrees._IIBTree.IIBTree'

........
......
....
etc
".

Please help me ...
_______________________________________________
For more information about ZODB, see the ZODB Wiki:
http://www.zope.org/Wikis/ZODB/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zodb-dev

Reply via email to