[Chris Withers]
> The alias I suggested is purely to mirror that of the oid_repr function,

Except p64 isn't oid_repr's inverse, so an alias for p64 suggesting it _was_
oid_repr's inverse would be confusing, because it would be lying.  There is
no inverse for oid_repr, and there isn't a need for one.  For any 8-byte
string oid S,

    p64(int(oid_repr(S), 0)) == S

so that's how to "get an inverse" of oid_repr if you really want one
(although I don't know why anyone would).

> and I would include it directly above of below the oid_repr function with
> bigger documentation clues for blind people like me ;-)

+1 on better documention:  improve docstrings, add comments, add overviews.
If anyone's worried about it, adding comments does not increase Python's
runtime <wink>.

> Does anyone have any non-pedantic reasons for not including this alias?

See my last msg -- -1 on increasing confusion.  Please, document what's
there already, _then_ see if it's still too confusing to use.  The
functionality already exists, and the names p64/u64 make a great deal of
sense as-is after you understand them.  No brief name can be self-evident
without reading the docs.  The primary problem now isn't the names, it's
that the docs are inadequate.

For more information about ZODB, see the ZODB Wiki:

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to