On Jan 12, 2007, at 6:53 AM, Terry Jones wrote:

In trying to debug some code last night and today, I ran across what looks to be a problem with ZODB 3.6. I'm not 100% sure, and I'm also not running the SVN code (see below). I'm on Mac OS X 10.4.8 with Python 2.4.3 from the
Darwin Ports collection.

When I got my mac, I think I tried this Python port and had problems with it.

I then just built my own Python from source and have been a happy camper.


So I went to install the latest ZODB. I found 3.7.0b3 at
http://cheeseshop.python.org/pypi/ZODB3/3.7.0b3 and I've made 3 attempts to
install this and none of them worked:

- using python setup.py install, which gets me raise TypeError, "dist must be a Distribution instance", and there's not much help for this to
    be found via google.

I couldn't reproduce this either on Linix or on my mac (10.4.8) with
the Python I built myself.

If you still care about this, I suggest building Python yourself and
trying again.


Jim Fulton                      mailto:[EMAIL PROTECTED]                Python 
CTO                             (540) 361-1714                  
Zope Corporation        http://www.zope.com             http://www.zope.org

For more information about ZODB, see the ZODB Wiki:

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to