Hi Jim

| I haven't had a chance to look at this yet, but I haven't forgotten  
| you.  I suspect that ZODB isn't being careful enough it its  
| requirements specification and that it needs a newer version of  
| zope.proxy than what you have installed.  FWIW, ZODB not only imports  
| but also passes it's extensive test suite for me.
| 
| How did you install ZODB?

On Mac OS X 10.4.8 and python 2.5 I see the same import error:

    Python 2.5 (r25:51918, Sep 19 2006, 08:49:13) 
    [GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
    Type "help", "copyright", "credits" or "license" for more information.
    >>> from zope.proxy.decorator import SpecificationDecoratorBase
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    ImportError: No module named decorator
    >>> import zope.proxy 
    >>> dir(zope.proxy)
    ['ClassType', 'IProxyIntrospection', 'ProxyBase', 'ProxyIterator', '_CAPI', 
'__all__', '__builtins__', '__doc__', '__file__', '__name__', '__path__', 
'__provides__', '_zope_proxy_proxy', 'getProxiedObject', 'interfaces', 
'isProxy', 'moduleProvides', 'non_overridable', 'queryInnerProxy', 
'queryProxy', 'removeAllProxies', 'sameProxiedObjects']

I installed ZODB via easy_install ZODB3-3.8.0b2.tar.gz

That pulled down, built, and installed zope.proxy

    Searching for zope.proxy
    Reading http://cheeseshop.python.org/pypi/zope.proxy/
    Reading http://svn.zope.org/zope.proxy
    Reading http://cheeseshop.python.org/pypi/zope.proxy/3.3.0
    Best match: zope.proxy 3.3.0
    Downloading 
http://cheeseshop.python.org/packages/source/z/zope.proxy/zope.proxy-3.3.0.tar.gz#md5=64128ab4feeb5bfd8a66c4cdd5192a31
    Processing zope.proxy-3.3.0.tar.gz
    Running zope.proxy-3.3.0/setup.py -q bdist_egg --dist-dir 
/tmp/easy_install-flef-Q/zope.proxy-3.3.0/egg-dist-tmp-DZ9VAL
    src/zope/proxy/_zope_proxy_proxy.c:748: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:752: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:754: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:760: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:748: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:752: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:754: warning: initialization from 
incompatible pointer type
    src/zope/proxy/_zope_proxy_proxy.c:760: warning: initialization from 
incompatible pointer type
    Adding zope.proxy 3.3.0 to easy-install.pth file

    Installed 
/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/zope.proxy-3.3.0-py2.5-macosx-10.3-fat.egg

which is the only available zope.proxy version at
http://cheeseshop.python.org/packages/source/z/zope.proxy/

My sys.path looks fine, with no other ZODB in it ahead of 
/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/ZODB3-3.8.0b2-py2.5-macosx-10.3-fat.egg

Let me know if you have suggestions on how I could dig into this
further. I'll probably try ZODB3 3.8.0b1 to see if I get the same result
and/or try with the latest zope.proxy.

Regards,
Terry
_______________________________________________
For more information about ZODB, see the ZODB Wiki:
http://www.zope.org/Wikis/ZODB/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zodb-dev

Reply via email to