On Thu, Jul 29, 2010 at 2:49 PM, Christian Theune <c...@gocept.com> wrote:
> On 07/29/2010 02:42 PM, Hanno Schlichting wrote:
>> The docs explicitly state that Python 2.4 is no longer supported at all.
>>
>> Go with the times and use Python 2.6 or 2.7 ;)
>
> The docs also say that ZEO supports older clients. The application that I
> currently have in mind has no chance of moving from Python 2.4 but probably
> would benefit from a threaded ZEO server which I'd like to verify.

I think we discussed the Python version support policy on this list in
regard to the changes to exception classes. It's documented pretty
clearly:

ZODB 3.10 requires Python 2.5 or later.

Note --
   When using ZEO and upgrading from Python 2.4, you need to upgrade
   clients and servers at the same time, or upgrade clients first and
   then servers.  Clients running Python 2.5 or 2.6 will work with
   servers running Python 2.4.  Clients running Python 2.4 won't work
   properly with servers running Python 2.5 or later due to changes in
   the way Python implements exceptions.

So the ZODB 3.10 server requires 2.5. You cannot run clients with
Python 2.4 with a server running 2.5. Therefor you will have to update
the application at some point.

Hanno
_______________________________________________
For more information about ZODB, see the ZODB Wiki:
http://www.zope.org/Wikis/ZODB/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zodb-dev

Reply via email to