On 10/07/2010 10:53 PM, Jim Fulton wrote:
> [...snip...]
> OK, I have no idea what the problem is.  It may be a ZODB bug, since,
> apparently, this
> showed up when you upgraded to ZODB 3.10.0b8, although I can't image
> what the bug
> could be.
> You're going to have to debug this, at least by whittling this down to a 
> example
> that someone who doesn't have your software can run.

Thanks for the nudge to debug this further. Turned out to be problem with the 
application. Somehow (I do not know yet know how or when) an object derived 
OOBTree got corrupt. Corrupt in the sense that although looking up individual 
items from the OOBTree worked, when dereferencing the entire contents caused 
traceback I posted (for example, even with a repr or in case of the traceback, 
when setstate() was being called while loading the object).

> Some suggestions:
> - Figure out what the class of the object is and what the value of state is.
> - Try creating an instance outside your app and passing that state to
> it to see if you get the same error.

Although the mapping has now been restored back to a sane state (by recreating 
another instance manually and replacing the original), I haven't yet figured 
how it got to be in that state. I'll investigate further to see if there is a 
possibility of creating a reproducer. This might be a problem with karl's[1] 
CaseInsensitiveOOBTree (which is less likely since it is just a thin wrapper) 

Anyways, thanks and cheers,

[1] http://karlproject.org/architecture.html

random spiel: http://lonetwin.net/
what i'm stumbling into: http://lonetwin.stumbleupon.com/
For more information about ZODB, see the ZODB Wiki:

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to