Hi all,

I'm getting an error when trying to run zeopack (zeopack.py) from the
command line. This is a Linux server running the following "Zope
Version": "Zope 2.10.9-final, python 2.4.6, linux2". The Plone version
is 3.3.1

The error message is "ImportError: No module named ZEO.ClientStorage".
Here's my attempt to run the command:

myhost:/soft/Plone/Zope-2.10.9-final-py2.4/lib/python/ZEO/scripts #
Traceback (most recent call last):
  File "/soft/Plone/Zope-2.10.9-final-py2.4/lib/python/ZEO/scripts/zeopack.py",
line 33, in ?
    from ZEO.ClientStorage import ClientStorage
ImportError: No module named ZEO.ClientStorage

I saw some threads about this error that suggested to set / expand the
PYTHONPATH environment variable. I did not have that PYTHONPATH
environment variable defined.  So, I tried to define that variable:

myhost:# export

myhost:# env | grep -i pythonpath

... but I still get the same "ImportError: No module named
ZEO.ClientStorage" error message when trying to run again the command,
event after having defined PYTHONPATH with the above values.  :(

Could anyone give me some tips / pointers to what I'm doing wrong /
should be doing instead, please?

Thanks in advance!  :)

Best wishes,
Ricardo Dias Marques
lists AT ricmarques DOT net
Identi.ca / Twitter: @ricmarques
For more information about ZODB, see http://zodb.org/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to